用pip安装出错[英] Error installing with pip

本文是小编为大家收集整理的关于用pip安装出错的处理方法,想解了用pip安装出错的问题怎么解决?用pip安装出错问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

尝试卸载使用 pip 安装的软件包,我卸载了一些,现在 pip 不起作用.我尝试安装熊猫:

[sudo] pip install pandas

这是错误:

Requirement already satisfied (use --upgrade to upgrade): pandas in /usr/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): python-dateutil in /usr/local/lib/python2.7/dist-packages (from pandas)
Downloading/unpacking pytz (from pandas)
Downloading pytz-2013b.zip (535kB): 535kB downloaded
Running setup.py egg_info for package pytz
/usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'zip_safe'
  warnings.warn(msg)
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
   or: -c --help [cmd1 cmd2 ...]
   or: -c --help-commands
   or: -c cmd --help

error: invalid command 'egg_info'
Complete output from command python setup.py egg_info:
/usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'zip_safe'

warnings.warn(msg)

usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]

 or: -c --help [cmd1 cmd2 ...]

 or: -c --help-commands

 or: -c cmd --help

error: invalid command 'egg_info'

----------------------------------------
Command python setup.py egg_info failed with error code 1 in /tmp/pip-build-root/pytz
Storing complete log in /root/.pip/pip.log

我有 Linux Mint Mate 15.我该如何解决这个问题??

推荐答案

使用 pip install -U setuptools 更新您的 setuptools 安装.

本文地址:https://www.itbaoku.cn/post/1727893.html