如何安装特定的phalcon框架2.0版本?[英] how to install specific phalcon framework version 2.0.?

问题描述

我有一个与2.0版

一起工作正常的应用程序

为此,我无法安装Phalcon版本2.0仅最新版本3.2.2正在安装..

那么如何安装V 2.0 .. ??

安装来源: https://phalconphp.com/en/down/down/linux

curl -s "https://packagecloud.io/install/repositories/phalcon/stable/script.deb.sh" | sudo bash
sudo apt-get install php5-phalcon
sudo apt-add-repository ppa:phalcon(2.0x)/legacy

以下类似问题没有帮助我解决问题. 如何安装Phalcon版本2

推荐答案

好吧,在PackageCloud或Launchpad上的Phalcon 2.0.x的最后一个软件包版本,因此您只需要使用git:

git clone https://github.com/phalcon/cphalcon
cd cphalcon
git checkout 2.0.x
cd build
sudo ./install

添加到php.ini- extension=phalcon.so

其他推荐答案

首先,这是官方2.0安装文档安装phalcon 2.0 您发布的文档适用于我们当前版本,该版本与PHP7兼容,我不确定如何与2.0.x

一起使用

我将作如何安装Phalcon版本2 将使用GitHub的发行版,例如 phalcon-2.0.13 stable 这是选择主要版本的最简单方法,因此,如果2.0.13不合适,您可能会在GitHub上找到所需的版本. phalcon发行

本文地址:https://www.itbaoku.cn/post/1739777.html