PhantomJS与Selenium的版本兼容性[英] PhantomJS version compatibility with Selenium

问题描述

我无法将 Selenium WebDriver(又名 Selenium 2)2.53.0 与 PhantomJS 1.2.0 一起使用.有什么解决方法吗?我必须使用 WebDriver 2.41.0 而不是最新版本 (2.53.0).

推荐答案

phantomjsdriver-1.2.1.jar 与 Selenium-2.53.0 一起提供.如果 phantomjsdriver-1.2.0 不能与 Selenium-2.53.0 一起使用,您可以使用 phantomjsdriver-1.2.1 .pom.xml 的依赖代码如下:

<dependency>
<groupId>org.seleniumhq.selenium</groupId>
<artifactId>selenium-java</artifactId>
<version>2.53.0</version>
</dependency>

<dependency>
<groupId>com.codeborne</groupId>
<artifactId>phantomjsdriver</artifactId>
<version>1.2.1</version>
</dependency>

本文地址:https://www.itbaoku.cn/post/1740068.html