哪个版本的Casperjs与Phantomjs合作良好?[英] Which version of CasperJS is working well with PhantomJS?

问题描述

但是,当我们每个新手Casperjs或Phantom的人中,通常都会发生这种情况....他们开始结合最新版本并尝试执行教程(来自旧的日期资源)>>结果是. ..许多部分的错误.

因此,要克服这个问题. 我希望两个版本都有一些笔记,可以并排运行. 例如

casperjs 1.0.4和phantomjs 1.8.2 >>不是一个好选择, 因为this.getElementsInfo()的功能在代码内无法正常工作.

推荐答案

  • casperjs 1.1 -beta3与phantomjs 1.9.0-1.9.8.
  • git 最新的Casperjs phantomjs 1.9.0-2.0.0.
  • 避免使用 phantomjs 1.9.8,如果您需要干净的输出.
  • 我建议安装多个版本:2.0.0、1.9.8和1.9.7并行为不同的可执行文件.然后,您可以在Windows上使用set PHANTOMJS_EXECUTABLE=myphantomjs或Linux上的export PHANTOMJS_EXECUTABLE=myphantomjs在调用Casperjs之前很容易地在它们之间进行更改.我倾向于使用可执行文件phantomjs200,phantomjs198和phantomjs197躺在周围.

本文地址:https://www.itbaoku.cn/post/1740158.html