MADlib apt安装,怎么做?[英] MADlib apt install, how to?

本文是小编为大家收集整理的关于MADlib apt安装,怎么做?的处理方法,想解了MADlib apt安装,怎么做?的问题怎么解决?MADlib apt安装,怎么做?问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

MADlib 是最完整、最高效(功能更快)和最可靠的 PostgreSQL 数学库...在 官方下载没有关于 Debian 或 UBUNTU "即插即用安装"的线索.

检查其他字体,最好的(最简单的)是 2013 年的旧指令 apt-get it.

...还有一些 lost-script of 2014... 评论说"可以下载 .rpm 包并安装在 Ubuntu 中,只需使用 Alien 命令将包转换为 .deb 即可工作".

<小时>

问题:安装 MADLib 的安全且最简单的方法?
今天(2017 年)在 UBUNTU 16 LTS 和 PostgreSQL v9.6 上.

<小时>

注意和第二个问题:Debian stable 和 UBUNTU LTS 一起是最流行的网络服务器 Linux 发行版,因此 .deb 是最重要的发行形式... 为什么 MADlab 的维护者拒绝看到它?为什么不欢迎 .deb 用户?
apt 或转换后的.deb 存在一些技术或许可问题?

<小时>

编辑

我有两种类型的 SQL 服务器,如所述的 v9.6,但最重要的是 PostgreSQL v9.5.X(!抱歉,我们完全打算使用 v9.6服务器).

PostgreSQL 9.5.X 在 UBUNTU 16 LTS (xenial) 中的情况

  • psql --version 进入其中,select version(); 显示 v9.5.6.

  • 命令 pgxnclient install madlib 显示

    You need to install postgresql-server-dev-X.Y for building 
    a server-side extension or libpq-dev for building a client-side application.
    ERROR: command returned 1: ['/usr/bin/pg_config', '--libdir']

... pg_config 不是配置文件,而是一个shell工具...所以我通过 sudo apt-get install libpq-dev 安装了它(好的!)

  • 命令 pgxnclient install madlib 显示
      INFO: best version: madlib 1.10.0
      INFO: saving /tmp/tmpip4ngh/madlib-1.10.0.zip
      INFO: unpacking: /tmp/tmpip4ngh/madlib-1.10.0.zip
      INFO: running configure
      error: cmake 2.8 or higher must be present to configure and install MADlib
      /tmp/tmpip4ngh/madlib-1.10.0/configure: 13: exit: Illegal number: -1
      ERROR: configure failed with return code 2
    

...但不是"CMake version error",是"no CMake"错误,所以使用了apt install cmake!

但它们是一个 cmake 问题,

pgxnclient install madlib
INFO: best version: madlib 1.10.0
INFO: saving /tmp/tmpspQ3zf/madlib-1.10.0.zip
INFO: unpacking: /tmp/tmpspQ3zf/madlib-1.10.0.zip
INFO: running configure
-- The C compiler identification is GNU 5.4.0
-- The CXX compiler identification is GNU 5.4.0
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/g++
-- Check for working CXX compiler: /usr/bin/g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Could NOT find Boost
-- No sufficiently recent version (>= 1.47) of Boost was found. Will download.
-- Found PythonInterp: /usr/bin/python (found version "2.7.12") 
CMake Error at src/ports/postgres/cmake/FindPostgreSQL.cmake:161 (message):
  Found pg_config ("/usr/bin/pg_config"), but pg_config.h file not present in
  the server include dir (/usr/include/postgresql/9.5/server).
Call Stack (most recent call first):
  src/ports/postgres/cmake/PostgreSQLUtils.cmake:66 (find_package)
  src/ports/postgres/CMakeLists.txt:360 (determine_target_versions)

-- Configuring incomplete, errors occurred! See also "/tmp/tmpspQ3zf/madlib-1.10.0/build/CMakeFiles/CMakeOutput.log". INFO: building extension make -C build all make[1]: Entering directory '/tmp/tmpspQ3zf/madlib-1.10.0/build' make[1]: * No rule to make target 'all'. Stop. make[1]: Leaving directory '/tmp/tmpspQ3zf/madlib-1.10.0/build' Makefile:5: recipe for target 'all' failed make: * [all] Error 2 ERROR: command returned 2: make PG_CONFIG=/usr/bin/pg_config all

推荐答案

Madlib 是 Postgres 扩展.许多人通过 pgxn.org 分发他们的扩展,就像 CPANRubygems 的 Postgres 扩展.所以安装它的命令是这样的:

pgxnclient install madlib

之后,你可以在任何你喜欢的数据库中说CREATE EXTENSION madlib.

注意你可能需要先安装一些依赖,例如:

sudo apt-get install cmake postgresql-plpython-9.6 pgxnclient

这是 2013 年的链接告诉您的内容,在我看来仍然正确.(请注意,我将 plpython 从 9.1 更改为 9.6.)我尝试在 Postgres 9.5 + Ubuntu 14.04 上自己从 pgxn 安装 madlib,并且成功了.

至于为什么 madlib 的人不分发 .deb 文件:你可以随时问他们,但 pgxn 是共享 Postgres 扩展的主流方式.这就像为您的编程语言提供包管理器一样.

本文地址:https://www.itbaoku.cn/post/1763834.html