在尝试使用geodjango安装GIS应用程序时出现安装错误?[英] Installation error while trying to install a gis application using geodjango?

本文是小编为大家收集整理的关于在尝试使用geodjango安装GIS应用程序时出现安装错误?的处理方法,想解了在尝试使用geodjango安装GIS应用程序时出现安装错误?的问题怎么解决?在尝试使用geodjango安装GIS应用程序时出现安装错误?问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

django.core.exceptions.ImproperlyConfigured: Cannot determine PostGIS version for database "geodatabase". GeoDjango requires at least PostGIS version 1.3. Was the database created from a spatial database template?

这是我在学习本教程时遇到的错误 http://invisibleroads.com/tutorials/geodjango-googlemaps-build.html

推荐答案

当我没有正确使用 POSTGIS 模板来创建我的数据库时,我收到了这个错误(正如错误提示的那样).您是否正确使用空间数据库模板安装 PostGIS 你是否使用 -T template_postgis 创建了你的数据库?

createdb -U postgres -T template_postgis -O geouser geodatabase

本文地址:https://www.itbaoku.cn/post/1764065.html