无法获得资源'https://dl.google.com/dl/android/maven2/com/android/support/support-fragment/28.0.0/support-fragment-28.0.0.aar&#39。[英] Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/support/support-fragment/28.0.0/support-fragment-28.0.0.aar'

本文是小编为大家收集整理的关于无法获得资源'https://dl.google.com/dl/android/maven2/com/android/support/support-fragment/28.0.0/support-fragment-28.0.0.aar&#39。的处理/解决方法,可以参考本文帮助大家快速定位并解决问题,中文翻译不准确的可切换到English标签页查看源文。

问题描述

我想构建一个简单的基于片段的应用程序,但我无法加载lib.

无法获得资源'

全部始于实施'com.android.support:support-v4:28.0.0' 这不起作用

推荐答案

  1. 您要么在(应用程序)build.gradle中导入错误的依赖性,要么
  2. 您的设备/网络上有一些DNS问题.
  3. 您也许也可以尝试一下; 将其添加到应用程序build.gradle
repositories {
        maven { url "https://maven.google.com" }
    }

我希望这是因为它们很容易解决.让我知道它是否已解决.

编辑:添加3

本文地址:https://www.itbaoku.cn/post/2091070.html

问题描述

I want to build a simple fragment based App, but I can't load the lib.

Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/support/support-fragment/28.0.0/support-fragment-28.0.0.aar'

What I tried:

  1. update Proxy settings
  2. delete Proxy
  3. settings Check
  4. check Connection
  5. Add:
   // Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {
    repositories {
        google()
        jcenter()

    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.4.1'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        google()
        jcenter()
         maven {
             url 'https://maven.google.com'
        }

    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

Gradle.Properties

apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    defaultConfig {
        applicationId "com.example.fragmentmanagementmainactivity"
        minSdkVersion 23
        targetSdkVersion 28
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android-optimize.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    implementation 'com.android.support:appcompat-v7:28.0.0'
    implementation 'com.android.support.constraint:constraint-layout:2.0.0-beta1'
    testImplementation 'junit:junit:4.13-beta-3'
    androidTestImplementation 'com.android.support.test:runner:1.0.2'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
    implementation 'com.android.support:support-v13:28.0.0'
    implementation 'com.android.support:support-fragment:28.0.0'
}

All started with implementation of 'com.android.support:support-v4:28.0.0' which wasn't working

推荐答案

  1. You're either importing a wrong dependency in your (app) build.gradle, or
  2. You've got some DNS problems on your device/network.
  3. You might be able to try this too; Add this to the app build.gradle
repositories {
        maven { url "https://maven.google.com" }
    }

I hope it's either of these because they're easy to solve. Let me know if it got solved.

Edit: add 3