Nokogiri无法在OS X上安装[英] Nokogiri fails to install on OS X

本文是小编为大家收集整理的关于Nokogiri无法在OS X上安装的处理方法,想解了Nokogiri无法在OS X上安装的问题怎么解决?Nokogiri无法在OS X上安装问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

关于此问题有很多帖子,但是,可能有两个原因,为什么Nokogiri(版本1.6.x,1.7.x或1.8.x)无法在OSX.

上安装.

相关文章:

推荐答案

命令行未安装:

这是最容易检查和修复的方法:在终端窗口中运行xcode-select --install,然后尝试通过运行gem install nokogiri.

有些人报告说他们使用gem install nokogiri -- --use-system-libraries

libxml,libxlt太近了:

这种情况是由于这样的事实是,这些图书馆在使用自制的库安装时可能太新了.这种情况会导致安装过程中的不兼容和致命错误.

要解决此问题,有2个主要选项:

gem install nokogiri -- --use-system-libraries --with-xml2-include=/usr/include/libxml2 --with-xml2-lib=/usr/lib/

brew unlink libxml2
brew unlink libxslt
brew unlink libiconv
sudo xcode-select --install
gem install nokogiri

有关原因的更多详细信息,请参阅 github on Github上的第1166期 .

本文地址:https://www.itbaoku.cn/post/786321.html