更新Ruby-Gems时出现未知主机错误[英] Unknown Host Error while updating Ruby-Gems

本文是小编为大家收集整理的关于更新Ruby-Gems时出现未知主机错误的处理方法,想解了更新Ruby-Gems时出现未知主机错误的问题怎么解决?更新Ruby-Gems时出现未知主机错误问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我正在尝试使用以下方法更新 ruby​​ gem:

gem update --system 

但我收到错误:

<块引用>

错误:执行 gem 时 ...(Gem::RemoteFetcher::UnknownHostError)没有这样的名称(https://rubygems.org/specs.4.8.gz).

推荐答案

不确定你安装的是什么版本的rubygems,但是有三种方法可以解决:

  1. 网络问题 - 稍后再试.
  2. 您拥有的版本无法更新,您需要以其他方式安装

    <块引用>

    注意:当没有安装 ruby​​gems-update 时,RubyGems 1.1 和 1.2 会出现升级问题.如果您看到没有要更新的内容,您将需要使用以下说明.如果您安装了旧版本的 RubyGems,那么您仍然可以分两步完成:

    $ gem install rubygems-update # might need to be admin/root

    $ update_rubygems

  3. 你不得不弄脏你的手:

有关详细信息,请参阅 https://rubygems.org/pages/download

本文地址:https://www.itbaoku.cn/post/786342.html