无法获得GemFile允许捆绑更新[英] can't get gemfile to allow for bundle update

本文是小编为大家收集整理的关于无法获得GemFile允许捆绑更新的处理方法,想解了无法获得GemFile允许捆绑更新的问题怎么解决?无法获得GemFile允许捆绑更新问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我是一个红宝石/rails newbie.

这是我的gemfile:

source 'https://rubygems.org'
ruby '2.0.0'
#ruby-gemset=railstutorial_rails_4_0

gem 'rails', '4.0.0'

group :development do
  gem 'sqlite3', '1.3.8'
  gem 'ruby-debug-ide'
end

gem 'sass-rails', '4.0.0'
gem 'uglifier', '2.1.1'
gem 'coffee-rails', '4.0.0'
gem 'jquery-rails', '3.0.4'
gem 'turbolinks', '1.1.1'
gem 'jbuilder', '1.0.2'
gem 'wash_out', :git => 'git://github.com/inossidabile/wash_out.git'
gem 'haml'
gem "railties", "~> 4.0.0"

group :doc do
  gem 'sdoc', '0.3.20', require: false
end

在捆绑更新中,我得到这个:

Bundler could not find compatible versions for gem "railties":
  In Gemfile:
    rails (= 4.0.0) ruby depends on
      railties (= 4.0.0) ruby

    sass-rails (= 4.0.0) ruby depends on
      railties (4.0.1.rc1)

Sass-Rails问题应该解决,因为我正在使用〜>正确?如何在同时安装轨道和SASS-RAILS?

推荐答案

如果将sass-rails play rails在您的GEMFILE之前,它会正确解析.

其他推荐答案

您的问题是您一次只能使用一个版本的宝石. ~>只允许版本更改该宝石.

您需要更改sass-rails的版本,您需要4.0.1.

其他推荐答案

您应该在Gemfile中更新以下行:

gem 'rails', '4.0.0'

gem 'rails', '~> 4.0.0'

然后运行bundle update.

本文地址:https://www.itbaoku.cn/post/786355.html