Ruby Sass,无法解决依赖[英] ruby sass, unable to resolve dependancies

本文是小编为大家收集整理的关于Ruby Sass,无法解决依赖的处理方法,想解了Ruby Sass,无法解决依赖的问题怎么解决?Ruby Sass,无法解决依赖问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我下载了两个GEM文件:Sass-3.3.7.gem&compass-0.12.6.gem

i RAN gem install --local Sass-3.3.7.gem它安装了.

随后是compass的相同命令,但出现了错误:

 unable to resolve dependencies: compass requires sass (~>3.2.19)

我正在安装它们,因为我没有连接,因为我没有连接.有人知道解决方案是什么?

推荐答案

指南针0.12.6显然取决于sass〜> 3.2.19,这意味着SASS的版本应大于3.2和小于3.3,因此基本上是指南针需要SASS 3.2.x.您有两个选择.

  1. 还下载SASS 3.2.19,安装两个版本的SASS,自己使用最新版本并使Compass快乐.
  2. 只需安装SASS 3.2.19并自己使用它,这显然只有在您不需要SASS 3.3中引入任何功能的情况下才起作用.

其他推荐答案

安装SASS 3.2.19:

sudo gem install sass -v 3.2.19 

我不需要SASS 3.3.7,Jekyll不断找到最新的版本,所以我被卸载了SASS 3.3.7:

sudo gem uninstall sass

sass似乎没有覆盖以前的版本,因此我仍然安装了3.3.2(如果安装了多个版本,它可以选择要卸载的版本),所以我也卸载了该版本.

其他推荐答案

您可以运行gem dependency <gem name>查看GEM依赖项和所需版本的列表.

本文地址:https://www.itbaoku.cn/post/786359.html