终端中的Cocoapods安装错误[英] Cocoapods installation error in terminal

本文是小编为大家收集整理的关于终端中的Cocoapods安装错误的处理方法,想解了终端中的Cocoapods安装错误的问题怎么解决?终端中的Cocoapods安装错误问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

尝试安装可可录时,我会遇到以下错误,任何人都可以帮助我调试吗?

MacBook-Pro:~ saiteja$ sudo gem install cocoapods
Password:
ERROR:  Error installing cocoapods:
    activesupport requires Ruby version >= 2.2.2.
MacBook-Pro:~ saiteja$ 

推荐答案

sudo gem安装activeSupport -v 4.2.6

其他推荐答案

首先安装旧版本的" ActiveSupport"(既与Ruby 2.0兼容,也与Cocoapods兼容),然后安装Cocoapods. $ sudo gem安装activeSupport -v 4.2.6

其他推荐答案

这是我完全面临的问题. 首先,您需要安装活动脚本:

sudo gem install activesupport -v 4.2.6
sudo gem install -n /usr/local/bin cocoapods

本文地址:https://www.itbaoku.cn/post/786373.html