无法要求openssl,安装OpenSSL并重建ruby(首选)或使用非HTTPS来源[英] Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS sources

本文是小编为大家收集整理的关于无法要求openssl,安装OpenSSL并重建ruby(首选)或使用非HTTPS来源的处理方法,想解了无法要求openssl,安装OpenSSL并重建ruby(首选)或使用非HTTPS来源的问题怎么解决?无法要求openssl,安装OpenSSL并重建ruby(首选)或使用非HTTPS来源问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我正在尝试安装 jekyll,但遇到了错误.我正在运行 Mac OS X 10.11.4 (El Capitan).

$gem install jekyll
ERROR : While executing gem ... (Gem::Exception)
        Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS sources
$gem source -l
https://ruby.taobao.org
$which openssl
/usr/local/bin/openssl

欢迎您提出如何解决此错误的建议.

推荐答案

是否可能 /usr/local/ 不是它搜索文件和库的文件夹(它在 /user/ 中搜索).Apple 决定在 OS X 下删除 openssl(在 10.11 (SDK) 中,该库仍然存在,但标题不存在).

本文地址:https://www.itbaoku.cn/post/786415.html