如何在Mavericks上从Gemfile修复libv8错误?[英] How to fix libv8 error from Gemfile on Mavericks?

本文是小编为大家收集整理的关于如何在Mavericks上从Gemfile修复libv8错误?的处理方法,想解了如何在Mavericks上从Gemfile修复libv8错误?的问题怎么解决?如何在Mavericks上从Gemfile修复libv8错误?问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

当我运行bundle install时,我得到

An error occurred while installing libv8 (3.11.8.17), and Bundler cannot continue.
Make sure that `gem install libv8 -v '3.11.8.17'` succeeds before bundling.

libv8是lunchy和therubyracer gem的依赖关系.

我已锁定在3.11.8.17

上的Gemfile.lock libv8 gem中

但我发现我可以将其降级为3.3.10.4

捆绑安装/更新:libv8(therubyracer)安装失败(具有本机扩展)

如何做到这一点?

我也发现工作3.11.8.17 gem但不知道如何在我的系统上实现它. https://github.com/cowboyd/libv8/issues/107_dsuecomment- 26146673

推荐答案

您实际上可以在mavericks上安装该版本:

gem install libv8 -v 3.11.8.17 -- --with-system-v8

我可以用rbenv和Ruby 1.9.3p448(Ruby 1.9.3p448)确认

在这里看到类似的线程安装libv8 gem在o x 10.9+上P>

其他推荐答案

需要重新安装libv8

$ gem uninstall libv8
$ brew install v8
$ gem install therubyracer

其他推荐答案

尝试使用

宝石"Therubyracer","〜> 0.10.2"到Gemfile

,它将安装依赖的gem libv8(3.3.10.4),并且构建宝石本机扩展失败问题已解决.

本文地址:https://www.itbaoku.cn/post/786431.html