安装旧的Cocoapods?[英] Install old cocoapods?

本文是小编为大家收集整理的关于安装旧的Cocoapods?的处理方法,想解了安装旧的Cocoapods?的问题怎么解决?安装旧的Cocoapods?问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我的整个项目目前都是WACK,因为没有任何依赖关系符合Cocoapods 1.0.数以百万计的podspec不起作用,还有多个其他问题,这些问题曾经是警告,现在正在制造停止错误……如此令人沮丧.

我尝试删除~/.cocoapods,sudo gem uninstall cocoapods和sudo gem install cocoapods -v 0.39.0,并且发生了相同的错误.看起来无论如何正在安装它?

cocoapods (0.39.0)
cocoapods-core (1.0.0, 0.39.0)
cocoapods-deintegrate (1.0.0)
cocoapods-downloader (1.0.0, 0.9.3)
cocoapods-plugins (1.0.0, 0.4.2)
cocoapods-search (1.0.0, 0.1.0)
cocoapods-stats (1.0.0, 0.6.2)
cocoapods-trunk (1.0.0, 0.6.4)
cocoapods-try (1.0.0, 0.5.1)

如何使用100%旧版本,直到固定这些液体?

推荐答案

步骤1 运行sudo gem install cocoapods -v 0.39.0,这将安装您想要的版本.

步骤2 Run sudo gem list,它将为您提供您安装的所有宝石及其版本的列表;您会注意到,您已经安装了多个版本的Cocoapods.

步骤3 卸载您不需要sudo gem uninstall cocoapods -v 1.0的版本.

步骤4 确认您现在正在运行使用pod --version的可可录的正确版本.

本文地址:https://www.itbaoku.cn/post/786457.html