如何降级捆绑或升级轨道?[英] How to downgrade bundler or upgrade rails?

本文是小编为大家收集整理的关于如何降级捆绑或升级轨道?的处理方法,想解了如何降级捆绑或升级轨道?的问题怎么解决?如何降级捆绑或升级轨道?问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我为我的Gemfile添加了Omniauth Gem并试图运行捆绑安装,但收到了关于Rails和Bundler版本不兼容的消息.我试图更新rails,但是与其他宝石有关不兼容的消息.如何降级Bundler到1.0?

$ bundle install
Fetching gem metadata from http://rubygems.org/......
Fetching gem metadata from http://rubygems.org/..
Bundler could not find compatible versions for gem "bundler":
  In Gemfile:
    rails (= 3.0.0) ruby depends on
      bundler (~> 1.0.0) ruby

  Current Bundler version:
    bundler (1.1.1)

This Gemfile requires a different version of Bundler.
Perhaps you need to update Bundler by running `gem install bundler`?

$ bundle update rails
Fetching gem metadata from http://rubygems.org/......
Fetching gem metadata from http://rubygems.org/..
Bundler could not find compatible versions for gem "bundler":
  In Gemfile:
    factory_girl_rails (>= 0) ruby depends on
      bundler (~> 1.0.0) ruby

  Current Bundler version:
    bundler (1.1.1)

推荐答案

尝试以下命令:

gem uninstall bundler
gem install bundler --version '1.0.0'

其他推荐答案

安装下降版本的Bundler,尝试:

gem install bundler --version '<= 0.10.6'

所以你可以安装两个版本(检查:gem list bundler/bundler _0.9.26_ -v),然后使用特定版本,例如:

bundle _0.9.26_ install

了解更多:如何升级/降级rubygems 在rubyforge

其他推荐答案

如果您想要降级或升级bundler 当我们尝试卸载全局Bundler版本时存在一些问题.我解决了自己的技术问题.按照步骤:

步骤1:运行:gem list bundler

*** LOCAL GEMS ***
bundler (2.0.2, 1.17.3)
bundler-unload (1.0.2)
rubygems-bundler (1.4.4)

我有2个Bundler版本2.0.2和1.17.3.现在我卸载2.0.2,因为我将使用1.17.3.但是当我尝试使用此命令卸载2.0.2 gem uninstall bundler --version '2.0.2'时,我会发现一个错误:

ERROR:  While executing gem ... (Gem::InstallError)
bundler is not installed in GEM_HOME, try:
    gem uninstall -i /home/habib/.rvm/gems/ruby-2.3.1@global bundler

因为它是我的全球bundler.但是错误消息有解决方案.然后我尝试第2步.

步骤2:运行gem uninstall -i /home/habib/.rvm/gems/ruby-2.3.1@global bundler

输出: Successfully uninstalled bundler-2.0.2

步骤3:我再次检查我的bundler列表gem list bundler

*** LOCAL GEMS ***

bundler (1.17.3)
bundler-unload (1.0.2)
capistrano-bundler (1.2.0)
rubygems-bundler (1.4.4)

这里我只有一个绑定器1.17.3,我可以使用它我的任何项目

检查您的bundler版本:运行bundler -v

output: Bundler version 1.17.3

本文地址:https://www.itbaoku.cn/post/786468.html