试图使用rspec,但得到一个错误:rspec-core 2.2.1已经被激活,但我的Gemfile需要rspec-core 2.1.0[英] Trying to use rspec, but getting an error that rspec-core 2.2.1 has been activated, but my Gemfile requires rspec-core 2.1.0

本文是小编为大家收集整理的关于试图使用rspec,但得到一个错误:rspec-core 2.2.1已经被激活,但我的Gemfile需要rspec-core 2.1.0的处理方法,想解了试图使用rspec,但得到一个错误:rspec-core 2.2.1已经被激活,但我的Gemfile需要rspec-core 2.1.0的问题怎么解决?试图使用rspec,但得到一个错误:rspec-core 2.2.1已经被激活,但我的Gemfile需要rspec-core 2.1.0问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我已经更新了我的宝石.我创建了一个示例 Rails 应用程序,并在我的 Gemfile 中有以下内容:

source 'http://rubygems.org'

gem 'rails', '3.0.3'
gem 'sqlite3-ruby', :require => 'sqlite3'

group :development do
  gem 'rspec-rails'
end

group :test do
  gem 'rspec'
  gem 'webrat', '0.7.1'
end

但是,当我运行"rspec spec/"时,我收到以下消息:

/home/jeff/.rvm/gems/ruby-1.9.2-p0/gems/bundler-1.0.7/lib/bundler/runtime.rb:27:in `block in setup': 
You have already activated rspec-core 2.2.1, but your Gemfile requires rspec-core 2.1.0. 
Consider using bundle exec. (Gem::LoadError)

推荐答案

尝试使用 bundle update rspec 和 bundle update rspec-rails.您位于根目录中的 Gemfile.lock 文件可能正在为每个 gem 指定一个版本号.

本文地址:https://www.itbaoku.cn/post/786478.html