Rails Installtion error :The 'atomic' native gem requires installed build tools[英] Rails Installtion error :The 'atomic' native gem requires installed build tools

本文是小编为大家收集整理的关于Rails Installtion error :The 'atomic' native gem requires installed build tools的处理方法,想解了Rails Installtion error :The 'atomic' native gem requires installed build tools的问题怎么解决?Rails Installtion error :The 'atomic' native gem requires installed build tools问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我正在 Windows 上安装 Rails 3.我安装了最新的 ruby​​ 2.0.0,并更新了 gems.但是当我使用 gem install rails 安装 rails 时,出现了成功的消息,但最后我找到了

 ERROR:  Error installing rails:
     The 'atomic' native gem requires installed build tools

    Please update your PATH to include build tools or download the DevKit
    from 'http://rubyinstaller.org/downloads' and follow the instructions
    at 'http://github.com/oneclick/rubyinstaller/wiki/Development-Kit'

请帮帮我...

推荐答案

我也遇到了同样的问题.经过大量研究,我找到了一个可行的解决方案.

运行这个命令:

pik list

它应该告诉你

187: ruby 1.8.7 (2010-08-16 patchlevel 302) [i386-mingw32]
192: ruby 1.9.2p290 (2011-07-09) [i386-mingw32]
193: ruby 1.9.3p327 (2012-11-10) [i386-mingw32]
200: ruby 2.0.0p247 (2013-06-27) [i386-mingw32]

如果它不指向 Ruby 版本 200,则运行以下命令:

pik use 200

现在运行以下命令将 DevKit 增强到已安装的 Ruby:

ruby dk.rb install

最后,运行以下命令:

gem install rails

这将为 Ruby 2.0 安装最新的 Rails 版本 4.

本文地址:https://www.itbaoku.cn/post/786485.html