如何在服务器启动时修复 "你的Ruby版本是2.3.0,但你的Gemfile指定为2.2.5 "的问题[英] How to fix "Your Ruby version is 2.3.0, but your Gemfile specified 2.2.5" while server starting

本文是小编为大家收集整理的关于如何在服务器启动时修复 "你的Ruby版本是2.3.0,但你的Gemfile指定为2.2.5 "的问题的处理方法,想解了如何在服务器启动时修复 "你的Ruby版本是2.3.0,但你的Gemfile指定为2.2.5 "的问题的问题怎么解决?如何在服务器启动时修复 "你的Ruby版本是2.3.0,但你的Gemfile指定为2.2.5 "的问题问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我在运行服务器时遇到此错误,我该如何解决?

在此处输入图片描述

推荐答案

为了兼容性,你最好安装 Ruby 2.2.5

如果您使用的是 rvm:

rvm install 2.2.5
rvm use 2.2.5

如果你使用的是 rbenv:

rbenv install 2.2.5
rbenv local 2.2.5

如果您不能通过 rbenv 更改 ruby​​ 版本,阅读此处

本文地址:https://www.itbaoku.cn/post/786521.html