无法安装ruby gems-zlib错误[英] cannot install ruby gems - zlib error

本文是小编为大家收集整理的关于无法安装ruby gems-zlib错误的处理方法,想解了无法安装ruby gems-zlib错误的问题怎么解决?无法安装ruby gems-zlib错误问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我试图安装一些Ruby Gems,这样我可以使用Ruby在我收到Twitter消息时通知我.但是,在执行 gem update --system 之后,我每次尝试执行 gem install ruby gems时得到的控制台输出. (以及从 gem environment 的输出).



  C:\\ \\ data \ ruby​​> gem install twitter 
错误:执行gem时(Zlib :: BufError)
缓冲区错误

C:\data\ruby> gem update --system
更新RubyGems
错误:执行gem时(Zlib :: BufError)
缓冲区错误

C:\data\ ruby> gem环境
RubyGems环境:
- RUBYGEMS VERSION:1.2.0
- RUBY VERSION:1.8.6(2007-03-13 patchlevel 0)[i386-mswin32]
- 安装目录:c:/ruby/lib/ruby/gems/1.8
- RUBY EXECUTABLE:c:/ruby/bin/ruby.exe
- 可执行目录:c:/ ruby​​ / bin
- RUBYGEMS平台:
- ruby​​
- x86-mswin32-60
- 创业板路径:
- c:/ruby/lib/ruby/gems/1.8
- 创业板配置:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- 远程来源:
- http://gems.rubyforge.org/

解决方案

我今晚也开始接受这个. Google搜索引发了一系列无法​​提供结果的建议.



  gem update --system 


以及一些来自jamis的代码粘贴,它应该替换package.rb中的函数,但它应该替换的原始代码无处可用被发现.



重新安装rubygems没有帮助.我现在重新安装红宝石.........并且它是固定的.虽然痛苦.


本文地址:https://www.itbaoku.cn/post/786533.html