获取错误:在部署/迁移到Heroku时更新RubyGems[英] Getting error: update rubygems while deploying/migrating to Heroku

本文是小编为大家收集整理的关于获取错误:在部署/迁移到Heroku时更新RubyGems的处理方法,想解了获取错误:在部署/迁移到Heroku时更新RubyGems的问题怎么解决?获取错误:在部署/迁移到Heroku时更新RubyGems问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我在迁移到heroku时收到以下错误.

Installing hoe (2.9.4) /usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/installer.rb:170:in >安装':锄头需要rubygems版本> = 1.4.尝试"GEM更新 - 系统"以更新RubyGems本身. (宝石:: installerror)`

它是Ruby Gems版本已过期.有人知道如何解决这个问题?

使用Ruby 1.9.2 <9.2的Rails 3.0.5

bundler

Using rake (0.8.7) 
Using RedCloth (4.2.2) 
Using abstract (1.0.0) 
Using activesupport (3.0.5) 
Using builder (2.1.2) 
Using i18n (0.5.0) 
Using activemodel (3.0.5) 
Using erubis (2.6.6) 
Using rack (1.2.2) 
Using rack-mount (0.6.14) 
Using rack-test (0.5.7) 
Using tzinfo (0.3.26) 
Using actionpack (3.0.5) 
Using mime-types (1.16) 
Using polyglot (0.3.1) 
Using treetop (1.4.9) 
Using mail (2.2.17) 
Using actionmailer (3.0.5) 
Using arel (2.0.9) 
Using activerecord (3.0.5) 
Using activeresource (3.0.5) 
Using archive-tar-minitar (0.5.2) 
Using authlogic (2.1.6) 
Using xml-simple (1.0.15) 
Using aws-s3 (0.6.2) 
Using bcrypt-ruby (2.1.4) 
Using block_helpers (0.3.3) 
Using bundler (1.0.10) 
Using columnize (0.3.2) 
Using diff-lcs (1.1.2) 
Using json (1.5.1) 
Using gherkin (2.3.6) 
Using term-ansicolor (1.0.5) 
Using cucumber (0.10.2) 
Using nokogiri (1.4.4) 
Using cucumber-rails (0.4.1) 
Using daemons (1.0.10) 
Using database_cleaner (0.6.7) 
Using factory_girl (1.3.3) 
Using faker (0.9.5) 
Using fastercsv (1.5.4) 
Using formtastic (1.2.3) 
Using gem_plugin (0.2.3) 
Using haml (3.0.25) 
Using hoe (2.9.4) 
Using thor (0.14.6) 
Using railties (3.0.5) 
Using rails (3.0.5) 
Using kaminari (0.12.0) 
Using ruby_core_source (0.1.5) 
Using linecache19 (0.5.12) 
Using meta_search (1.0.4) 
Using mongrel (1.2.0.pre2) 
Using paperclip (2.3.11) 
Using pg (0.11.0) 
Using pickle (0.4.7) 
Using populator (1.0.0) 
Using render_inheritable (1.0.0) 
Using rspec-core (2.5.1) 
Using rspec-expectations (2.5.0) 
Using rspec-mocks (2.5.0) 
Using rspec (2.5.0) 
Using rspec-rails (2.5.0) 
Using ruby-debug-base19 (0.11.25) 
Using ruby-debug19 (0.11.6) 
Using test-unit (1.2.3) 
Using will_paginate (3.0.pre2) 
Using typus (3.0.10) from https://github.com/fesplugas/typus.git (at master) 
Using webrat (0.7.3)

更新:

heroku stack

aspen-mri-1.8.6
* bamboo-ree-1.8.7
bamboo-mri-1.9.2 (prepared, will migrate on next git push)

更新2:

错误跟踪

Installing hoe (2.9.4) /usr/ruby1.9.2/lib/ruby/1.9.1/rubygems/installer.rb:170:in `install': hoe requires RubyGems version >= 1.4. Try 'gem update --system' to update RubyGems itself. (Gem::InstallError)
    from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/source.rb:95:in `install'
    from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/installer.rb:55:in `block in run'
    from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/spec_set.rb:12:in `block in each'
    from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/spec_set.rb:12:in `each'
    from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/spec_set.rb:12:in `each'
    from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/installer.rb:44:in `run'
    from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/installer.rb:8:in `install'
    from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/cli.rb:225:in `install'
    from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/vendor/thor/task.rb:22:in `run'
    from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/vendor/thor/invocation.rb:118:in `invoke_task'
    from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/vendor/thor.rb:246:in `dispatch'
    from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/lib/bundler/vendor/thor/base.rb:389:in `start'
    from /usr/ruby1.9.2/lib/ruby/gems/1.9.1/gems/bundler-1.0.7/bin/bundle:13:in `<top (required)>'
    from /usr/ruby1.9.2/bin/bundle:19:in `load'
    from /usr/ruby1.9.2/bin/bundle:19:in `<main>'
   FAILED: http://devcenter.heroku.com/articles/bundler
!Heroku push rejected, failed to install gems via Bundler

推荐答案

好的我解决了它.

锄头只是与heroku一起使用,因为它们不支持新版本的rubygems(这是Heroku这样的痛苦)

我在这里添加了锄头宝石:

group :test, :development do
  gem "hoe"
end

并在我的控制台中键入以下内容:

heroku config:add BUNDLE_WITHOUT="development:test"

本文地址:https://www.itbaoku.cn/post/786557.html