无法安装ZenTest 4.8.4[英] Can't install ZenTest 4.8.4

本文是小编为大家收集整理的关于无法安装ZenTest 4.8.4的处理方法,想解了无法安装ZenTest 4.8.4的问题怎么解决?无法安装ZenTest 4.8.4问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

当我尝试安装 ZenTest 时:

gem install ZenTest

我收到以下错误:

<块引用>

无效的 gemspec[C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/specifications/ZenTest-4.8.4.gemspec]:不正确的要求 ["<2.1, >= 1.8"]

我尝试清理 gems 并删除 ZenTest 无济于事.

怎么了?

推荐答案

我刚刚与 ZenTest 的作者 Ryan Davis 进行了交谈.他告诉我这是由于 RubyGems 中的一个错误,他们正在准备一个版本来修复它.

同时,降级到 4.8.3.

本文地址:https://www.itbaoku.cn/post/786591.html