更新到gem 1.8.1时出现rubyonrails错误[英] rubyonrails error when update to gem 1.8.1

本文是小编为大家收集整理的关于更新到gem 1.8.1时出现rubyonrails错误的处理方法,想解了更新到gem 1.8.1时出现rubyonrails错误的问题怎么解决?更新到gem 1.8.1时出现rubyonrails错误问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我将 gem 更新到最新的 1.8.1现在当我使用 rails 命令时我收到以下错误

NOTE: Gem::Specification#default_executable= is deprecated with no replacement. 
It will be removed on or after 2011-10-01.
Gem::Specification#default_executable= called from /Library/Ruby/Gems/1.8/specifications/rubygems-update-1.7.2.gemspec:11.
NOTE: Gem::Specification#default_executable= is deprecated with no replacement. It will be removed on or after 2011-10-01.
Gem::Specification#default_executable= called from /Users/Haxrat/.gem/ruby/1.8/specifications/RedCloth-4.2.7.gemspec:10.

推荐答案

这些只是弃用警告.rubygems 中的许多内容在此版本中已弃用,请阅读 http:///blog.zenspider.com/2011/05/rubygems-18-is-coming.html了解更多详情.

本文地址:https://www.itbaoku.cn/post/786615.html