运行 "gem install rails "时出错[英] Error when run "gem install rails"

本文是小编为大家收集整理的关于运行 "gem install rails "时出错的处理方法,想解了运行 "gem install rails "时出错的问题怎么解决?运行 "gem install rails "时出错问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我的配置:

  • 操作系统:Ubuntu 12.04
  • rvm 版本:1.25.14
  • 红宝石版本:2.1.0p0
  • gem 版本:2.2.1

    $ 哪个红宝石/home/tauhidul35/.rvm/rubies/ruby-2.1.0/bin/ruby$哪个rvm/home/tauhidul35/.rvm/bin/rvm$ 哪个宝石/home/tauhidul35/.rvm/rubies/ruby-2.1.0/bin/gem$哪个捆绑/home/tauhidul35/.rvm/gems/ruby-2.1.0@global/bin/bundle

现在当我运行命令时,我得到错误:

$ gem install rails
ERROR:  While executing gem ... (NoMethodError)
undefined method `ord' for nil:NilClass

如果我运行命令,我会得到错误:

$ sudo apt-get install rails
E: Unable to locate package rails

我是 Ubuntu 和 Ruby on Rails 的新手.请帮帮我.

推荐答案

感谢大家的帮助.
当我使用 Ubuntu 更新管理器更新我的计算机时,这个问题终于解决了.
不知道为什么更新后问题解决了.但我相信它可以通过全部更新来解决.

特别感谢 majioa.

本文地址:https://www.itbaoku.cn/post/786638.html