缺少Rails 2.3.4 gem。尽管它已经安装了![英] Missing the Rails 2.3.4 gem. Even though it's installed!

本文是小编为大家收集整理的关于缺少Rails 2.3.4 gem。尽管它已经安装了!的处理方法,想解了缺少Rails 2.3.4 gem。尽管它已经安装了!的问题怎么解决?缺少Rails 2.3.4 gem。尽管它已经安装了!问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

奔跑的雪豹.试过卸载,重新安装.每当我运行 rake 任务时仍然会出现相同的错误.

<块引用>

mbpro:redmine shereef$ ruby​​ -v
ruby 1.8.7 (2009-06-12 补丁级别174)[i686-darwin10.0.0]

mbpro:redmine shereef$ rails -v
导轨 2.3.4

mbpro:redmine shereef$ 哪个导轨
/usr/local/bin/rails

mbpro:redmine shereef$ gem -v
1.3.5

mbpro:redmine shereef$ 哪个宝石
/usr/local/bin/gem

mbpro:redmine shereef$ rake -v
(在/Users/shereef/Documents/Code/BetterMeans/redmine)
缺少铁轨2.3.4 宝石.请gem install -v=2.3.4 rails,更新你的Rails 的 config/environment.rb 中的 RAILS_GEM_VERSION 设置你已经安装的版本,或者注释掉 RAILS_GEM_VERSION 到使用安装的最新版本.

mbpro:redmine shereef$ 哪个 rake
/usr/bin/rake

mbpro:redmine shereef$ $PATH
-重击:/usr/local/bin:/usr/local/sbin:/usr/local/mysql/bin:/opt/local/bin:/opt/local/sbin:/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/usr/X11/bin:没有这样的文件或目录

mbpro:redmine shereef$

推荐答案

在 Fedora 12 上你需要

$ gem install -v=1.0.1 rack

让捆绑的导轨工作.

本文地址:https://www.itbaoku.cn/post/786706.html