为什么'捆绑更新'安装古代宝石?[英] Why is 'bundle update' installing ancient gems?

本文是小编为大家收集整理的关于为什么'捆绑更新'安装古代宝石?的处理方法,想解了为什么'捆绑更新'安装古代宝石?的问题怎么解决?为什么'捆绑更新'安装古代宝石?问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

一切正常正常工作,直到蓝色,捆绑更新决定"更新"到一些宝石的一些旧版本.有任何想法吗?我被困惑了!

Gemfile没有为AWRY Gems指定版本.例如.

gem 'rails'

我做...

bundle update

和(!)...

Using rails (0.9.5)

如果我指定版本.例如.

gem 'rails', '~> 3.0'

然后没关系.

Using rails (3.0.7)

源'http://rubygems.org'

宝石版1.8.3,RVM版本1.6.14

只有一些宝石是错误的. Mongoid是另一个.它在1.0.6.谢谢!

推荐答案

问题解决了.这是一个GEM冲突.我把它煮沸到...

只有这两个宝石:

gem 'rails'
gem 'i18n'

你得到1018n 0.6.0(最新的)但轨道是在3.0.5(3.0.7的最新时).

然后只有这三个:

gem 'rails'
gem 'i18n'
gem 'delayed_job'

你得到:

Gems included by the bundle:
  * actionmailer (0.6.1)
  * actionpack (1.4.0)
  * activerecord (1.6.0)
  * activesupport (3.0.7)
  * bundler (1.0.13)
  * daemons (1.1.3)
  * delayed_job (2.1.4)
  * i18n (0.6.0)
  * rails (0.9.5)  <-- Yikes! that brings back memories!
  * rake (0.9.0)

我没有深入了解Bundler的宝石依赖关系,但这就是导致它的原因.有趣的!当然,无论如何都没有必要包括I18N Gem,因此删除了修复事物(或指定GEM版本).

其他推荐答案

试试这个.

只是更新你的捆绑程序,可能是任何一个旧的宝石与最新的创业板相互冲突,这类问题出现了.

'gem install bundler'

然后'bundler install'

如果再次发现错误,则删除gem.lock文件,然后运行bundler install.它可能会解决这个问题.

本文地址:https://www.itbaoku.cn/post/786719.html