我可以使用RVM为所有用户维护一个单一版本的Ruby吗?[英] Can I use RVM to maintain a single version of Ruby for all users?

本文是小编为大家收集整理的关于我可以使用RVM为所有用户维护一个单一版本的Ruby吗?的处理方法,想解了我可以使用RVM为所有用户维护一个单一版本的Ruby吗?的问题怎么解决?我可以使用RVM为所有用户维护一个单一版本的Ruby吗?问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我喜欢 RVM.我意识到它的主要用例是让不同的用户在不同版本的 Ruby 之间切换.但是,假设我正在将 Rails 应用程序部署到服务器,并且我只想运行单个版本的 Ruby.特别是,我想要 1.9.2,使用 RVM 安装它很容易,但没有它会很痛苦.有没有一种方法可以说"我希望这成为所有用户的规范 Ruby 安装"(以及它的所有 gem),而不必手动创建一堆符号链接并在每次更新到更新时更改它们Ruby 发布?

推荐答案

以 root 身份安装 RVM 并执行 sudo rvm use 1.9.2 --default.默认情况下,任何采购 /usr/local/rvm/scripts/rvm 的用户都将拥有 1.9.2.

本文地址:https://www.itbaoku.cn/post/786733.html