在 SceneKit 中支持 Collada/DAE 模型有哪些要求?[英] What are the requirements for supporting Collada/DAE models in SceneKit?

本文是小编为大家收集整理的关于在 SceneKit 中支持 Collada/DAE 模型有哪些要求?的处理方法,想解了在 SceneKit 中支持 Collada/DAE 模型有哪些要求?的问题怎么解决?在 SceneKit 中支持 Collada/DAE 模型有哪些要求?问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我收到了来自几种不同 3D 创作工具(Rhino、Blender、Cinema4D 等)的 Collada (DAE) 文件,并且发现有时无法加载模型.当模型加载失败时,Xcode 不提供任何信息.它只是显示一条警告,提示"无法打开文件."

在为我导出 DAE 文件时,我的 3D 设计师是否应该注意任何要求——特定的 DAE 版本、有限的功能子集等?

当然,我搜索了 Apple 的文档,但没有找到任何有关 DAE 要求的信息.

推荐答案

避免使用 Collada 1.5 版(据我所知,默认情况下只有 Cinema4D 导出到 1.5,但它有一个导出 1.4 的选项).SceneKit 不支持 Collada 1.5.然后,根据我使用 Maya 和 3DSMax 的经验,"openCollada"导出器(免费插件)比内置导出器提供更好的结果.

本文地址:https://www.itbaoku.cn/post/924521.html