创建我的第一个Cocoapod时问题[英] Issue when creating my first CocoaPod

本文是小编为大家收集整理的关于创建我的第一个Cocoapod时问题的处理方法,想解了创建我的第一个Cocoapod时问题的问题怎么解决?创建我的第一个Cocoapod时问题问题的解决办法?那么可以参考本文帮助大家快速定位并解决问题。

问题描述

我正在尝试创建我的第一个吊舱,并遵循本教程: http://www.sitepoint.com/creating-cocoapods/

但是当我这样做时:

pod spec lint GLLingoManager.podspec

我有以下错误:

$ pod spec lint GLLingoManager.podspec

 -> GLLingoManager (0.1.0)
    - ERROR | [OSX] unknown: Encountered an unknown error ([!] /Applications/Xcode.app/Contents/Developer/usr/bin/git clone https://github.com/xeppen/GLLingoManager.git /var/folders/v6/tdz6zc7j10j_k0pc1vy627zm0000gn/T/d20160504-76297-8l71fj --template= --single-branch --depth 1 --branch 0.1.0

Cloning into '/var/folders/v6/tdz6zc7j10j_k0pc1vy627zm0000gn/T/d20160504-76297-8l71fj'...
warning: Could not find remote branch 0.1.0 to clone.
fatal: Remote branch 0.1.0 not found in upstream origin
) during validation.

Analyzed 1 podspec.

[!] The spec did not pass validation, due to 1 error.

我不明白怎么了.我该怎么办?

推荐答案

为您的github repo添加0.1.0版本.图像从github ins incase链接死亡:

如何创建版本.

其他推荐答案

您已经指向podspec中的一个名为0.1.0的分支,您只需要将该名称的分支推向GitHub即可.许多人使用标签代替分支来指示每个POD版本都使用哪种使用,我建议您这样做而不是指向分支.请发布您的PODSPEC的源部分以获取更多具体详细信息.

其他推荐答案

您也可以在终端中的分支中添加标签:

git tag 0.1.0
git push --tags

本文地址:https://www.itbaoku.cn/post/924701.html