在Xcode中设置最小iOS版本
当我使用Cocoonjs构建我的HTML5 iPhone游戏时,我是Xcode的新手,但我想知道如何正确地设置最低iOS版本.我已经将部署目标设置为8.0,然后进行了干净,然后进行了构建,但是当我提交应用程序商店时,它说最低iOS版本为6.0. 我尝试的下一件事是在info.plist中手动更新此值 最小OS版本不匹配 - 架构('6.0')中的最小OS版本(LC_Version_min_iphoneos)用于架构('armv7')与info.plist 中的最小值('8.0')不同. 如何正确更新最小iOS版本而不拧紧我的二进制文件?我已经检查了其他线程,但他们都说只是为了更新部署目标. 解决方案 假设您正在针对8.x SDK进行构建,并且将部署目标设置为8.x或更高,这就足够了. 但是,我想您将部署目标设置为XCode中错误的位置.您需要将其设置在您的项目下,而不是在您的 target 下进行设置.另外,如果您有一个.xcconfig文件,则可以通过设置
14 2023-12-18
编程技术问答社区
CocoonJS & Cordova插件: "没有找到类 "的错误
如果我们有一个有关如何包装Cocoonjs的Cordova插件的例子. 我正在尝试在一个简单的示例中使用设备 - 导向插件(指南针),但是在应用程序初始化后,navigator.compass.getCurrentHeading()返回 Compasserror 与代码: Class not found 类名不能正确解决,因此config.xml文件可能出了问题. 结合了许多来源后,我的看起来像这样: ../www/config.xml HelloCordovaCompass
20 2023-04-06
编程技术问答社区
如何在HTML项目中使用CocoonJS
我有一个我想要制作跨平台的Eclipse中创建的HTML/JS项目.我遇到了Ludei的Cocoonjs,似乎是最好的选择(因为他们支持WebGL) 我按照 ludei site 上的指令 我在我的Android设备(Nexus 7)上有Cocoonjs发射器 我拉布了我的HTML/JS项目并将其推向SDCard 在根目录中有一个index.html文件 Cocoonjs Launcher在"您的应用程序"部分中成功地检测到我的ZIP项目 当我点击启动我的项目时,它是一个黑页面和错误日志: 找不到任何要执行的东西.如果您使用的是ZIP文件,请验证主HTML或JS文件是否位于ZIP文件的根目录(不在任何文件夹中).如果要直接使用文件夹路径,请检查主HTML或JS文件是否存储在其中. 我已经通过他们的网站和任何我能找到的论坛(不是很多),但没有想到它 我错过了什么?我有index.html,它没有打开. 解决方案 您是否zip文件夹一切顺利或您选择了
1246 2022-07-19
编程技术问答社区