Virtualbox 6.1.10, Ubuntu 20.04 在内核5.8.0上构建的返回状态不好,包virtualbox-dkms错误
不是文档的问题. 这是关于与虚拟盒6.1.10,Ubuntu 20.04和VirtualBox-DKMS软件包无法构建的失败apt-get install或update. 我最近与ubuntu 20.04和虚拟框6.1.10有一个问题-upgrade-cannot-install-virtuabox-dkms-nor-run"> there 和此处. 问题是,从Ubuntu软件中心安装了V6.1.10的虚拟框,该框与当前Ubuntu内核版本不兼容,v 5.8.xx. 这些都是已知的问题,但是当我错误地尝试从包装存储中重新安装Vbox时,我的问题出现了.以前,已编译并重新安装VirtualBox-DKMS可以删除功能软件包,并且错误(status 10)失败.所以我最终遇到了这样的错误: Loading new virtualbox-6.1.10 DKMS files... Building for 5.8.0-36-generic Building init
4 2023-11-19
编程技术问答社区
equivs 虚拟软件包版本号的语法
我尝试创建一个使用equivs的虚拟软件包,该软件包为python-oauthlib提供了python-oauthlib>>>>的软件包.问题在于,大多数依赖性问题都解决了,除了一个具有版本要求的软件包.我的问题是:如何在Provides字段中指定版本号? 我做了以下操作: 用 创建一个控制文件 equivs-control python-oauthlib 编辑控制文件如下: Section: misc Priority: optional Standards-Version: 3.9.2 Package: python-oauthlib-dummy Version: 0.6.1 Provides: python-oauthlib Architecture: all Description: Dummy Python OAuthlib package 构建软件包: equivs-build python-oauthlib 安装软件包: su
10 2023-11-19
编程技术问答社区
如何在使用'apt-get;安装软件包之前检查版本?
我正在考虑安装 hylafax+ 5.5.4版,上个月在我的 debian pc. 我检查了dpkg -l | grep "hylafax",发现当前版本为5.5.3.然后我检查了apt-cache search hylafax并看到包装可用,但是我看不到任何版本号. 如何找到apt-get>? 中可用的软件包版本 解决方案 好吧,我找到了. apt-cache policy 将显示版本详细信息. 它还显示了当前已安装了哪个版本以及可以安装哪些版本. 例如,apt-cache policy hylafax+ 其他解决方案 apt-cache policy $ apt-cache policy redis-server redis-server: Installed: (none) Candidate: 2:2.8.4-2 Version table: 2:2.
2 2023-11-17
编程技术问答社区
DPKG:警告:用于包装X'Missing的文件列表文件;假设软件包当前在Ubuntu 16.04中没有安装文件
我正在使用ubuntu 16.04与lubunut桌面环境.当我做apt-get upgrade时,我有以下问题超过3天.我不知道问题是什么意思以及如何解决. 注意:在尝试升级Linux-Header-4.4.66之前3天,但显示出错误.我删了它.现在,我回到了Linux-Header-4.4.64,以前工作正常. Error on sudo apt-get dist-upgrade (only last 15 line of 500+ line error): dpkg: warning: files list file for package 'libxcb-xkb1:amd64' missing; assuming package has no files currently installed dpkg: warning: files list file for package 'libvorbis-dev:amd64' missing; assuming pack
12 2023-11-09
编程技术问答社区
dpkg remove来停止进程
我目前正在运行Ubuntu 12.04.我创建了一个Debian软件包,该软件包当前已成功安装并启动了三个新进程.我还通过在/etc/init.d中放置以下脚本: 将这三个过程开始在运行时开始. # This example is from http://www.debian-administration.org/article/Making_scripts_run_at_boot_time_with_Debian # Also used http://wiki.debian.org/LSBInitScripts/ ### BEGIN INIT INFO # Provides: bleh # Required-Start: $remote_fs $syslog $network # Required-Stop: $remote_fs $syslog $network # Default-Start: 2 3 4 5 # Default-
6 2023-11-06
编程技术问答社区
无法在Ubuntu中安装Staruml 16.04
我正在使用Ubuntu 16.04-64位.我尝试使用.deb文件安装启动UML,并从Ubuntu软件中获取此消息: This software comes from a 3rd party and may contain non-free components 然后我尝试使用DPKG安装,并得到了: $ sudo dpkg -i StarUML-v2.7.0-64-bit.deb Selecting previously unselected package staruml. (Reading database ... 212003 files and directories currently installed.) Preparing to unpack StarUML-v2.7.0-64-bit.deb ... Unpacking staruml (2.7.0) ... dpkg: dependency problems prevent configuratio
26 2023-11-02
编程技术问答社区
在Ubuntu 16.04中安装cassandra时,dpkg oracle Jdk错误
我正在尝试在AWS EC2上安装Cassandra免费单节点Ubuntu实例.我正在关注此链接我成功完成了所有步骤,直到这个步骤 udo apt-get install cassandra 此步骤给我以下错误: Reading package lists... Done Building dependency tree Reading state information... Done cassandra is already the newest version (3.11.1). 0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded. 2 not fully installed or removed. After this operation, 0 B of additional disk space will be used. Do you want to continue? [Y/n] y Se
24 2023-11-02
编程技术问答社区
软件包php5没有安装候选者 (Ubuntu 16.04)
当我尝试在Ubuntu 16.04中使用以下代码安装PHP5时: sudo apt-get install php5 php5-mcrypt 我有以下错误: Reading package lists... Done Building dependency tree Reading state information... Done Package php5 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'php5' has no installation candidate 我尝试重新安装,但这无济于事. 我将15.10 Ubuntu更新为16.04
16 2023-11-02
编程技术问答社区
半数安装的软件包和python的循环依赖性
更新到Ubuntu 12.04至12.10时出了问题: root@ely:/sys/bus/usb/devices# dpkg -l | grep ^i[HUFW] iU libpython2.7 2.7.3-0ubuntu3.4 Shared Python runtime library (version 2.7) iU python 2.7.3-0ubuntu2.2 interactive high-level object-oriented language (default version) iU python-all 2.7.3-0ubuntu2.2 packa
8 2023-11-02
编程技术问答社区
dpkg: 错误处理存档(在安装Nodejs时)。
安装nodejs ]( https://i.stack.imgur.com/jmrit.jpg ) 我正在尝试安装nodejs,但在安装时面临此错误. 解决方案 我有相同的错误, Preparing to unpack .../nodejs_18.15.0-deb-1nodesource1_amd64.deb ... Unpacking nodejs (18.15.0-deb-1nodesource1) ... dpkg: error processing archive /var/cache/apt/archives/nodejs_18.15.0-deb-1nodesource1_amd64.deb (--unpack): trying to overwrite '/usr/share/systemtap/tapset/node.stp', which is also in package libnode72:amd64 12.22.9~dfsg-1ubuntu3
8 2023-11-02
编程技术问答社区
dpkg错误: pycompile:未找到
sudo apt-get remove --purge mysql-server mysql-client mysql-common 我尝试使用上述命令删除mySQL时会遇到以下错误: Reading package lists... Done Building dependency tree Reading state information... Done Package 'mysql-client' is not installed, so not removed The following package was automatically installed and is no longer required: php5-mysqlnd Use 'apt-get autoremove' to remove it. The following extra packages will be installed: mysql-server-co
2 2023-11-02
编程技术问答社区
如何覆盖dpkg-buildflags CFLAGS?
我有一个包裹: $ apt-get source 现在,我正在尝试使用它来构建: $ dpkg-buildpackage -uc -us -j8 在输出开始时,有说明: dpkg-buildpackage: export CFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security dpkg-buildpackage: export CPPFLAGS from dpkg-buildflags (origin: vendor): -D_FORTIFY_SOURCE=2 dpkg-buildpackage: export CXXFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protecto
14 2023-11-01
编程技术问答社区
dpkg:处理mysql-server包时出错(依赖性问题)?
当我尝试安装mysql-server时,错误会出现: dpkg: error processing package mysql-server (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: mysql-server-5.7 mysql-server E: Sub-process /usr/bin/dpkg returned an error code (1) 这是什么意思.有什么想法吗? 解决方案 dpkg返回错误代码1并不意味着任何具体的内容,但通常与依赖关系问题有关.在您的情况下,您尝试安装同一软件包的两个版本/实例,即mysql-server和mysql-server-5.7.因此,请执行以下操作以删除任何冗余依赖问题并安装功能的MySQL软件包 sudo apt-get clean sudo apt-g
10 2023-11-01
编程技术问答社区
dpkg:如何使用触发器?
我编写了一台小型CDN服务器,该服务器将新的pool-content-packages安装到该注册表池中. 我想使用触发器,而不是让每个pool-content-package调用cdn-server的init.d.这样,在安装所有软件包后,它将仅在安装运行结束时仅重新启动服务器. 在用debhelper支持的包装中使用触发器我该怎么办? 解决方案 您要寻找的是DPKG-Tiggers. 使用Debhelper构建Debian软件包的一种解决方案是: 步骤1) 创建文件debian/.triggers(用服务器包的名称替换 ). 步骤1a) 定义观看池目录的触发器.文件的内容将是: interest /path/to/my/pool 步骤1b) ,但您还可以定义一个命名的触发器,该触发器必须明确触发(请参见步骤3). 文件的内容:
70 2023-10-26
编程技术问答社区
Ansible命令模块说'|'是非法字符
我正在使用Ansible来部署我的项目,并尝试检查是否已安装了指定的软件包,但是我对IT任务有问题,这是任务: - name: Check if python-apt is installed command: dpkg -l | grep python-apt register: python_apt_installed ignore_errors: True 这是问题: $ ansible-playbook -i hosts idempotent.yml PLAY [lxc-host] *************************************************************** GATHERING FACTS *************************************************************** ok: [10.0.3.240] TASK: [idempotent | Ch
2 2023-09-01
编程技术问答社区
Ansible 中的一个角色,用于比较和输出所有服务器上安装的通用软件包?
我试图实现一个新的YML列表,并给我60多个服务器中的常见软件包. 这是草稿: - name: Save list of common packages hosts: all gather_facts: false tasks: - name: Get list of installed packages shell: dpkg-query -W -f="\${Package} \${Version}\n" | sort register: packages - name: Set fact for list of installed packages set_fact: installed_packages: "{{ packages.stdout_lines }}" - name: Add installed packages to group_vars add_hos
14 2023-08-21
编程技术问答社区
与rabbit-mq服务器的错误
我正在尝试使用DevStack在Ubuntu 12.04上设置OpenStack.现在,我遇到的错误是: Setting up rabbitmq-server (2.7.1-0ubuntu4) ... Starting rabbitmq-server: FAILED - check /var/log/rabbitmq/startup_{log, _err} rabbitmq-server. invoke-rc.d: initscript rabbitmq-server, action "start" failed. dpkg: error processing rabbitmq-server (--configure): subprocess installed post-installation script returned error exit status 1 No apport report written because MaxReports is reached a
14 2023-07-23
编程技术问答社区
需要安装PHP7和PHPMYADMIN Nginx/Ubuntu的两个依赖项
我已经进行了大量搜索">在这里,即使在遵循建议之后,我仍然会遇到以下错误. 以下软件包具有未满足的依赖性: phpMyAdmin:依赖性:php-getText,但不会安装 取决于:php-seclib,但不会安装 关于如何将php-getText和php-seclib添加到php7的任何建议? 解决方案 这不是PHP7或您要安装的任何其他软件的问题,而是与软件包管理器的配置有关. 它似乎是APT的输出,您链接到的问题也与Ubuntu有关,因此您要做的就是指示APT/DPKG/DPKG/aptitude自动安装依赖项,或者自己安装它们.假设您使用的是sudo apt-get install php7.0-cli之类的行,您只需要将依赖项添加到sudo apt-get install php7.0-cli php-seclib php-gettext.
34 2023-06-05
编程技术问答社区
deb包中的版权文件--如何
我正在尝试从二进制文件中创建一个DEB软件包,但我对版权文件有问题. 如果我在debian文件夹中放置一个名为版权的文件,它会抱怨两件事: 缺少版权 未知控制文件版权 如果我将其放在/usr/share/doc或/usr/share/doc/mypackage下,它根本不抱怨,但是在任何情况下,当我打开生成的debian软件包时,Ubuntu软件中心国家许可证:未知 使用:Ubuntu Raring 执行fakeroot dpkg-deb -z8 -Zgzip --build myproj 版权所有文件如下: Format: http://dep.debian.net/deps/dep5 Upstream-Name: myproj Source: Files: * Copyright: 2013 myproj. All rights reserved. License: Limited Use Software License Agreement
2 2023-05-16
编程技术问答社区
用dpkg-buildpackage创建多个软件包
我有一个源树结构,例如 - /src /moduleA /moduleB /common Modulea和Moduleb需要单独打包,但共享常见代码. 是否可以使用dpkg-buildpackage创建2个单独的二进制软件包? 谢谢! 解决方案 这是可能的.为了做到这一点,您应该修改控制文件. 当您使用dh_make -s时,您会有类似的东西: Source: yourpackage Section: unknown Priority: optional Maintainer: toto Build-Depends: debhelper (>= 8.0.0), autotools-dev Standards-Version: 3.9.4 Homepage: #Vcs-Git: git://git.debian.org/coll
34 2023-05-16
编程技术问答社区