Ubuntu 16 LTS-Eclipse窗口偏好设置不能正常工作
我刚刚安装了Ubuntu 16.04 LTS. 我在3月2日下载了Linux 64位的新鲜日食. 我正在使用最新的Oracle热点JDK 1.8更新91版本. 我注意到的第一件事是,在试图启用Eclipse一般偏好以显示堆栈用法时,打开"首选项"窗口花费了30秒,然后单击不同的树元素对偏好屏幕的内容没有影响. 其他菜单似乎正在正常工作,但尤其是无处可去的. 其他人是否遇到了这个问题,我该如何解决? 解决方案 问题是更新的GTK版本. 以下帖子解决了问题: 16-04 将以下内容设置为eclipse.ini --launcher.GTK_version 2 如Ubuntu Q&A中所述. 其他解决方案 将下面的两条线放入Eclipse.ini: - 启动器.gtk_version 2 行之前: - launcher.appendvmargs 其他解决方案 我使用左侧启动器遇到了问题. 有问题. 当我
20 2023-11-02
编程技术问答社区
Maven无法构建Java 8
今天,我试图在项目中使用lambda表达式.我将项目配置为无处不在的Java 8:构建路径,Java编译器,Maven-Compiler-Plugin,但是当我进行"运行/Maven install"时显示错误. java.lang.IllegalStateException: Failed to load ApplicationContext at org.springframework.test.context.CacheAwareContextLoaderDelegate.loadContext(CacheAwareContextLoaderDelegate.java:103) at org.springframework.test.context.TestContext.getApplicationContext(TestContext.java:122) at org.springframework.test.context.support.Dep
12 2023-10-24
编程技术问答社区
如何使用Eclipse Mars连接到Subversion
如何连接到Eclipse Mars发行的SVN存储库? 解决方案 [从原始"问题"复制为适当的问答] 使用Eclipse Marketplace安装颠覆性SVN团队提供商.在选项下,从可选软件中选择您需要的东西. 重新启动后,您可以使用 file > import 或 svn存储库 perspective percpective从SVN. 您会被提示.安装最新的SVNKIT(1.8.10) 其他解决方案 Eclipse帮助>>>安装新软件. 提供类型SVN,您会找到SVN客户端. 安装SVN客户端后,如果您尝试连接到SVN存储库,则将要求您安装连接器.您可以从显示的列表中选择任何人. 安装连接器后,重新启动日食.现在,您已经准备好从Eclipse开始SVN.
2 2023-10-06
编程技术问答社区
在eclipse(火星)上安装了一个插件,现在eclipse无法启动。我怎样才能卸载这个插件?
我安装了一个用于查看JSON文件的插件,它是Sweetlemonade的" JSON工具". 无论如何,安装它后,我尝试查看一个JSON文件(非常大的文件),我认为插件可能可以处理.好吧,当我这样做时,Eclipse崩溃了.现在,我无法让Eclipse重新开始.当它加载org.sweetlemonade.eclipse.json 时,它会失败 我已经在此处搜索了其他答案,但是接受的答案包括使用" P2导演"通过命令行卸载插件.唯一的问题是答案是旧版本的日食.我正在使用Eclipse Mars,在任何地方都找不到" P2导演"的安装. 如何手动卸载此插件并让Eclipse再次运行?我想解决这个问题,而不必重新安装和丢失我的项目设置. 解决方案 好吧,我设法通过导航到 来解决此问题 configuration/org.eclipse.equinox.simpleconfigurator/bundles.info 并删除了负责插件的行: org.sweet
0 2023-06-08
编程技术问答社区
如何升级新版本的Eclipse,而不是使用新下载的软件包?
我正在寻找步骤来升级我当前的日食版本( MARS )到最新版本(氧气),因为我过去很长时间都在使用火星所有设置,插件和所有历史记录 这是可能的吗? 注意:对于Java,C/C ++,PHP,JavaScript和Testers等任何类型的Eclipse. 解决方案 in 窗口>偏好:安装/更新>可用的软件网站 确保 最新eclipse同时发行 (或最新的Eclipse Release )存在更新站点,并检查了 .否则(在较旧版本或此更新网站以较新版本中删除时),单击添加... ,输入更新站点位置 https://download.eclipse.org/releases/latest ,然后单击确定. 帮助>检查更新 另请参见其他解决方案 这可能很有用. eclipse霓虹灯有一些包装结构变化. 其他解决方案 我不认为更新网站更新会更新eclipse.ini文件:您需要修复它. -startup plugins/org.eclipse.equ
32 2023-04-19
编程技术问答社区
如何在所有的合并都解决后摆脱Eclipse Git的 "冲突 "图标?
我在大量文件上获得了eclipse中的git冲突图标,即使我似乎解决了任何可能的冲突. 在Eclipse 4.5.2中,在项目视图中,我选择一个项目root,然后右键单击 - >与Branch Origin/Master 进行比较.接下来,我们看到团队同步视图.许多文件显示红色冲突图标. ,但它们不应该. 应该显示冲突的git登台视图是空的.我已经尝试了合并;进行合并(没有什么可提出的).我尝试从git登台视图中添加索引;甚至从团队同步视图中覆盖.比较本地和原点文件表明它们是相同的. git设置 autocrlf 是 true ,这不是问题. 这是反复发生的. 为什么我看到这个冲突图标?我怎么能摆脱它? 解决方案 您是否做过pull?还是您只是在Team Synchronization中进行比较的地方?根据我的经验,Team Synchronization观点使大多数人感到困惑. 通常,它应"只读".不要试图在这里解决任何冲突.根据默认,您将工
28 2023-03-26
编程技术问答社区
在Eclipse Mars中用JDK 1.6编译maven项目
我需要M2E的较旧版本,因为我需要使用较旧的Maven版本(我必须使用JDK 1.6编译某些项目). 在此处启动任何构建时(使用Java 1.6)的例外: Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli : Unsupported major.minor version 51.0 at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631) at java.lang.ClassLoader.defineClass(ClassLoader.java:615) at java.security.SecureClassLoader.defineClass(SecureCl
12 2023-03-15
编程技术问答社区
无法为Eclipse CDT安装LLVM工具链
我试图让clang再次在Eclipse上工作,因此我尝试在Eclipse Marketplace上安装LLVM工具链. 但是,当我单击"确认进行安装"时,我会收到以下错误 Unable to read repository at http://petrituononen.com/llvm4eclipsecdt/update. http://petrituononen.com/llvm4eclipsecdt/update is not a valid repository location. 这个网站似乎已经关闭,但我找不到任何其他来源. 有什么办法可以使叮当在eclipse火星上工作? 解决方案 这是从头开始的设置,对我有用(Ubuntu 14.04 + Eclipse Mars + Clang 3.6.2).您可能会对步骤8和9感兴趣. 安装Ubuntu 安装Java 8: sudo apt-add-repository ppa:webu
26 2023-03-11
编程技术问答社区
无法为Eclipse CDT安装LLVM工具链
我试图让clang再次在Eclipse上工作,因此我尝试在Eclipse Marketplace上安装LLVM工具链. 但是,当我单击"确认进行安装"时,我会收到以下错误 Unable to read repository at http://petrituononen.com/llvm4eclipsecdt/update. http://petrituononen.com/llvm4eclipsecdt/update is not a valid repository location. 这个网站似乎已经关闭,但我找不到任何其他来源. 有什么办法可以使叮当在eclipse火星上工作? 解决方案 这是从头开始的设置,对我有用(Ubuntu 14.04 + Eclipse Mars + Clang 3.6.2).您可能会对步骤8和9感兴趣. 安装Ubuntu 安装Java 8: sudo apt-add-repository ppa:webu
60 2023-03-11
编程技术问答社区
有没有办法改变eclipse中一些 "特殊 "的GUI颜色?
i在Linux/KDE上有一个安装的Eclipse Mars.2.但是颜色有很大的问题.因此,激活的工具栏按钮和无活动工具栏按钮之间没有区别.例如,在示例中," Project Explorer"视图的"带有编辑器的链接"按钮具有相同的背景颜色. 另一件事是我看不出是否选择了复选框或无线电按钮.看来检查/无线电框选择的前景颜色也与背景颜色相同.因此,在许多配置视图中,无法找出当前选择的内容,而wath则没有.在下一个屏幕截图中,至少必须选择一个"打开模式"单选按钮(我认为是"双击"按钮): 还请注意,颜色仅在日食中是错误的.在其他(本机)KDE应用中,我没有这些效果(例如,在复选框/无线电按钮的前景是黑色的 - 就像我预期的那样).还可以使用KDE"应用外观"中的颜色设置没有效果... 如何更改这些东西的颜色? 解决方案 好的.在以下网站上找到了我问题的解决方案: http://wwwww.jroller.com/andyl/andyl/endyl/ent
20 2023-03-09
编程技术问答社区
eclipse-mars on linux: Tooltip's中的黑色背景颜色
我知道有几个技巧可以更改Linux下Eclipse的Tooltip Windows的背景颜色(这些Windows在每个默认情况下具有某些Linux发行版本的黑色背景...).我尝试过的一些事情是: https://askubuntu.com/questions/questions/70599/how - 更换 - 镇定的 - 倒地彩色 https://askubuntu.com/questions/questions/1620/1620/固定可读 - 静止速度 https://askubuntu.com/questions/questions/35491/换tooltips-background-color-in-xfce 我已经用Eclipse Luna成功尝试了这一点.但这似乎与Eclipse Mars一起使用. 任何人都知道如何在linux下更改Eclipse Mars中工具提示的背景颜色? 编辑(2016-APR-06) 好的.在过去几个月中发现了几
22 2023-03-09
编程技术问答社区
退格键在Eclipse Mars中被还原了
我的Eclipse Mars(4.5.0)中的Backspace键就像删除密钥一样工作:它删除正确的字符而不是左侧字符.那真的很困惑 也许我不小心使用了快捷键? 我试图重新启动日食,但它不起作用.我还尝试将键绑定的首选项切换为" emacs"方案,然后再恢复为"默认". 任何帮助,谢谢! 编辑:该死,我刚刚发现Ctrl+X也不起作用! 解决方案 解决了: 转到"窗口 - >首选项".然后在树内导航到"常规 - >键". 在窗口的右侧,键入" delete",其中说"键入过滤文本". 查找命令:删除,绑定:backspace,然后在底部单击Unbrind命令按钮.单击应用,然后点击. 完成. 感谢@javich
8 2023-02-23
编程技术问答社区
Eclipse Mars不显示Jboss服务器
这是我尝试的东西 在Eclipse Mars中,请求助 - >安装新软件 单击添加按钮并粘贴我们情况下更新站点的URL: Eclipse火星工具用于JBOSS 现在选择 jbossas 工具插件,然后单击"下一步" 编辑: - 即使在上述要点之后,我也无法在Eclipse火星中看到JBOSS服务器,所以我尝试了以下 转到Eclipse Market Place->搜索JBOSS->然后从List Red Hat Jboss开发人员工作室(火星)9.0->确认 即使是现在,我也无法在Eclipse添加服务器列表中看到JBOSS服务器,因此无法在JBOSS服务器中运行我的应用程序. 任何人都可以告诉我为什么未在服务器列表中列出JBOSS服务器是什么问题? 编辑1: - 解决方案 您需要Java 8使用JBOSS工具4.3.0.beta1运行Eclipse,即使您不使用此版本的Java构建和部署(即,您仍然可以在Java 6或7上构建和部署
30 2023-01-31
编程技术问答社区
Eclipse Mars : 配置的运行时不足以为JAXB2.2提供一个实现
日食版本:火星. JDK 1.8. 我想创建一个JAXB项目.在JAXB Facet页面中,存在以下错误: 配置的运行时不足以为JAXB2.2 提供实现 您能给我一些有关如何解决的建议吗? 解决方案 我面临同样的问题.下面的FIX对我有用. 1) Select File->New ->Project 2) Choose JAXB Project from JAXB and click Next 3) Give Project Name and click Next 4) On the next window, just Click Next 5) On the next window (titled JAXB Facets), Choose "User Library" for JAXB implementation. Click "Download Library.." picture a
106 2023-01-31
编程技术问答社区
HibernateTemplate正在抛出java。lang.NoSuchMethodError:org。冬眠一场getFlushMode()--Spring4.2.6,Hibernate5.2
我已经在sessionFactory和缺少main()的情况下查看了类似的帖子.我的问题与他们无关.不确定任何罐子是否不匹配.我正在尝试使用JDK8使用Hibernate5.2代码的示例Spring4.2.6并获得此例外: Exception in thread "main" java.lang.NoSuchMethodError: org.hibernate.Session.getFlushMode()Lorg/hibernate/FlushMode; at org.springframework.orm.hibernate5.HibernateTemplate.checkWriteOperationAllowed(HibernateTemplate.java:1125) at org.springframework.orm.hibernate5.HibernateTemplate$12.doInHibernate(HibernateTemplate.java:619) at o
62 2023-01-06
编程技术问答社区
Eclipse Mars Glassfish 4.1-密钥值不得为空
我将在Eclipse Mars上集成玻璃鱼4.1.但是当玻璃鱼开始时,我收到了一个错误. "关键值不得为零." 我在任何地方都找不到分辨率.但是有一天发现了解决方案.在玻璃鱼和日食上有一些缺少的起始参数. 这是解决方案: 将该行添加到domain.xml -duser.language = en 和eclipse.ini 的线 -duser.language = en 解决了问题. 谢谢 解决方案 首先,尝试删除默认域(域1)并添加一个干净的域.还考虑更改调试端口. 我做到了,它起作用了,而上面的解决方案没有解决我的问题. 其他解决方案 当我使用Consol启动域时,我的应用程序运行.但是我在eclipce上运行的服务器,它不起作用. " -duser.language = en and to eclipse.ini的行"解决了此问题
22 2022-12-29
编程技术问答社区
Eclipse Mars。内容助理在按下点时没有完成
当我输入本地变量名称的第一部分时,请按 ctrl + space 为了显示内容助手,然后显示其全名变量并预选它. 在Eclipse Luna版本中,如果您在键盘上按.,并且内容助理显示了此变量实例的所有可访问成员. 使用Eclipse Mars,它在不完整的变量名称之后直接插入点. 如何将此行为切换回Eclipse Luna? public class A { public int member; public void possiblyAll(){ } } public class Test { private A aMemberNameWhichIsLong_1; private A aMemberNameWhichIsLong_2; private A aMemberNameWhichIsLong_3; public static void main(String[] args) {
10 2022-12-23
编程技术问答社区
在Eclipse Mars上用Java 1.6运行Ant
我下载了Eclipse(火星)的最新版本,并将所需的Java版本更改为1.6,因为我的项目使用Java 1.6. 我在Eclipse内部配置了安装的JRE,以使用Java 1.6. 但是,当我尝试执行蚂蚁目标时,它会产生错误: JRE版本小于1.7不支持. 我目前无法升级到java 1.7,在火星版本中使用Java 1.6吗? 解决方案 我在升级到Eclipse Mars后面临同样的问题. 我通过更改项目外部工具配置的运行时环境来解决此问题.. 我假设您知道如何将JDK7添加到Eclipse中的JRE 打开外部工具配置...然后将JRE更改为JDK 1.7 然后更改JRE 但这将创建另一个问题,编译的JAR将在JDK 7中,这将在JDK6的生产服务器上不起作用. 要解决这个问题,只需将任务中的目标属性更改为1.6 根据@dag和@chris的建议,这里是更新的ant Javac任务. 其他解决方案 我们使用a 修
136 2022-12-22
编程技术问答社区
Eclipse v4.5没有delta-pack。如何进行多平台的无头PDE构建?
现在,Eclipse 4.5已经淘汰,Eclipse团队决定不再构建所谓的" Delta-pack",我不知道如何使用Ant执行PDE无头构建. 官方PDE构建文档在这里 ?nav =%2f4_2_0 指出可变的"基本化"应指向"日食安装的位置,其中包含产品在功能/和插件/子目录中所需的所有预构建功能和插件" 使用v4.4,这很容易,此变量指向未拉链的三角洲包装的位置,所有平台特定的东西 但是,使用v4.5,如何获得/设置" Eclipse安装的位置,包含所有预构建的功能和插件...? 在这里 https://wiki.eclipse.org/building ,它解释了"首选的方法构建",这仅适用于从蚀中构建,而不是无头的构建,这不会创建一个结构. 所以我不知道如何在构建中设置"基本化"变量... thx (fyi,tycho不是-yet-对我们来说是一个选项..) 解决方案 "构建" Wiki页面还描述了如何"滚动您自己的" Delta
112 2022-09-04
编程技术问答社区
在CDT项目中使用不同的C++编译器的正确方法是什么?
我在Linux上使用Eclipse CDT Marsss 2(和Neon RC).我的发行版的默认C ++编译器是GCC 5.3.1,但是对于我的某些工作,我使用GCC 4.9.3.我想要关于我的项目使用GCC 4.9.3的所有内容:工具发现,C ++标准库,包含文件路径,索引器,预处理 - 所有这些. 做到这一点的正确方法是什么? Eclipse似乎具有拜占庭的"提供商"和"工具链"配置,我不想进行设置,我以后将无法撤消... 注意: 我确实尝试在一些预处理器中替换${COMMAND} /usr/bin/g++-4.9. std ::东西出现了红色和未解决.然后,我尝试查找设置用于索引的编译器版本的位置,但找不到. 解决方案 有两个可能的答案,具体取决于您是在执行"标准制造"还是" graged make".标准制作意味着您正在编写自己的makefiles并自己管理所有这些.托管制造意味着您让CDT创建makefiles并管理它们. 标准品 对于标准制造
22 2022-09-04
编程技术问答社区