如何使用eclipse进行C#开发?
是否可以将Eclipse用于C#开发? 如果是这样,该怎么做?您首选的组合是什么? 解决方案 虽然我看过一些部分烘烤的插件,但我不相信Eclipse内的Java工具甚至都有任何内容. 如果您在Windows上,最好使用Visual Studio.如果您在另一个平台上,请使用VM和Visual Studio,请使用我很乐意在Eclipse中有一个很好的C#支持(并且在某一时刻i 试图自己做这样的事情)的现实是,目前它只是不存在. 其他解决方案 如果您想要免费的IDE,请使用VisualStudio Express.甚至 SharpDevelop . Eclipse上的插件无法接近C#/.NET开发.如果您在单声道上,请尝试 monodevelop 或再次是SharpDevelop.
6 2024-04-18
编程技术问答社区
Eclipse CDT自定义编译器错误解析插件
我使用的是带有Eclipse CDT的不常见的编译器.我有一个很好的文件设置,这很好,但是我希望与编译器的错误/警告输出集成. 有人知道我可以采取哪些步骤来编写用于解析/支持编译器输出的插件?我认为这应该很容易,但是进入从哪里开始的进入障碍.如果Eclipse允许我做新的 - >编译器错误解析器插件或类似的内容. 谢谢 解决方案 不太简单... 首先确保已安装Eclipse PDE(插入式开发环境)和CDT SDK.如果不是这样,您需要告诉Eclipse下载它们(帮助 - >安装新软件). 然后,创建一个新的插件项目.在其扩展选项卡中,添加一个针对Point org.eclipse.cdt.core.errorparser的新扩展名.然后,您必须编写一些Java代码才能实际实现它.幸运的是,PDE使元工作相对简单.您将课堂名称放在适当的框中,然后单击"类*"超链接,它将为您创建骨架课. 我建议您将源代码抓住到CDT上,并查看gccerrorparse
12 2024-04-08
编程技术问答社区
启动失败。没有找到二进制文件。Eclipse Helios上的CDT
我在Ubuntu 10.04上使用Eclipse Helios,我正在尝试在其上安装CDT插件.我从这里下载在这里. 然后我转到安装新软件并选择zip文件(我不提取它,只需选择zip文件)即可.好的,它安装了,一切都可以正常工作,它显示可选功能, blah blah blah . 然后我创建了一个新的Helloworld项目.当我尝试运行它时,它会显示一个错误,并说: 启动失败.二进制找不到. 任何人都可以向我解释如何修复它吗? 谢谢. 解决方案 您必须在运行它之前构建可执行文件.因此,如果您不"构建"文件,那么它将无法链接和加载该对象文件,因此它没有执行所需的二进制数字. 因此,基本上右键单击Project -> Build Project -> Run As Local C/C++ Application应该执行技巧 其他解决方案 首先,您需要确保已建立该项目.您可以在工具栏中使用锤子图标构建一个项目.您可以选择构建调试或发布版本.
8 2024-04-06
编程技术问答社区
在运行时,在Eclipse中找到依赖的捆绑程序
eclipse捆绑包(例如,在激活器代码中)如何在运行时找到依赖的捆绑包实例?我想找到Eclipse选择满足依赖性要求的捆绑包,我不想自己解释清单. 一个示例:我想在当前捆绑包所依赖的所有捆绑中找到所有名为" Marker.txt"的资源.还有及依赖性.为了实现这一目标,我需要能够找到所有这些捆绑包. 解决方案 没有简单的方法来确定依赖关系. 最好的方法是通过Packageadmin接口.请参阅packageadmin和getImportingBundles的OSGI规格:您需要确定所有已安装的捆绑包,其中一个导出了捆绑包的一个或多个软件包.实现此目的的最简单方法是致电 packageadmin.getExportedPackages(捆绑包) bundles = null .这返回所有导出软件包的数组.然后,您需要迭代此数组并调用 exportPackage.getImportingBundles(). 其他解决方案 请参阅我对 这个问题. 4.3将有一个新的捆绑
10 2024-04-05
编程技术问答社区
出口 "Ant Buildfiles "和PDE工具->创建Ant Build文件之间的区别
我想为我的Xtext插件创建ANT构建脚本.我阅读了一些用于创建蚂蚁脚本的文章/教程.我遇到了自动创建ANT脚本的两种方法: 在插件项目上右键单击 - >导出 - > ant buildfiles 右键单击subtest.mf或build.properties或features.xml和pde工具 - >创建蚂蚁构建文件. 有人可以让我在上述两种方式之间有所区别吗? 解决方案 Export...>Ant Buildfiles将生成一个build.xml,以构建您的项目作为Java项目. PDE Tools > Create Ant Build File将创建一个蚂蚁文件以构建您的项目作为插件项目(使用PDE构建).
20 2024-04-05
编程技术问答社区
黑莓HelloWorld在8130模拟器下在Eclipse中部署,但不是950
我遵循www.thinkingblackberry.com/archives/21 中的步骤 如果我使用8130模拟器选择4.5.0 JDE,我可以导航到Helloworld图标,单击它,应用程序运行,我可以点击断点等. i然后切换到4.7.0 jde,删除模拟器文件(blackberry |擦除模拟器文件|擦除全部),然后在debug配置中将模拟器从默认值从默认值更改为9500 运行模拟器时,在模拟器出现时,我会在Eclipse控制台窗口中获得一系列消息.如果我然后单击BB按钮获取更多图标,然后单击"应用程序"按钮,我看不到任何Helloworld图标,并且我看不到任何向上/向下箭头表明有更多图标.我想念明显的东西吗?这是我看到的: 事先感谢您的任何帮助. 克里斯 解决方案 选择文件 - >加载COD,然后选择您的应用程序COD文件.之后,您的应用程序将在Home->您的设备上下载文件夹.
10 2024-04-05
编程技术问答社区
防止Eclipse构建.xml文件
我最近已经完成了(Archlinux)系统的全新安装.因此,我与最新的ADT插件(SDK Rev 21)一起安装了最新的Eclipse(Juno 4.2.1,我后悔). 现在,我正在观察一个我以前曾经有过的错误,但从那以后就修复了:当我处于Java的视角时,编辑了XML文件,然后单击绿色的" play"按钮以在我的我的身上按下新代码电话,Eclipse开始构建该特定的XML文件,而不是构建该XML文件所属的项目.我获得了无法打开的'xmlfilename.xml.out"文件.如果要构建项目,我必须deltte delte'xmlfilename.xml.out'文件,切换到java文件,然后重新单击该文件'''播放'按钮以使其正常工作. 可以将其视为错误还是我身边的一些错误配置?如果是一个错误,谁负责? Eclipse Juno,ADT还是其他前卫?可以修复它吗? 解决方案 在Eclipse中安装一些XML-Plugins时,会发生这种情况.不需要XML插件来开发A
12 2024-04-05
编程技术问答社区
如何让Ant将属性文件复制到classes目录下
我有一个可以使用ANT 正确构建和部署的项目 我想构建一个战争文件以部署项目. 我可以使所有工作正常工作,除了我无法将属性文件显示在类目录中. 我的属性文件位于这里: $ {resources_dir}/$ {app}/report.properties 这是我的构建文件的战争部分:
10 2024-04-05
编程技术问答社区
如何为checkstyle定义压制|定义,在ant和eclipse中都能使用。
我在项目CheckStyle中使用,并且已经定义了 suppressionfilter 配置.我使用Apache Ant通过连续集成进行自动构建. 我的问题来自以下情况:我不想将大量文件填充到基于项目的ir中,因此checkStyle.xml和puspressions.xml都在一个名为Conf的子目录中(用于构建的配置) .现在,蚂蚁和日食在寻找抑制作用方面有所不同.xml. ant使用基于项目的基于基于项目的抑制.xml,在我宣布蚂蚁任务以找到checkStyle.xml的基础配置.此checkStyle.xml现在包含以下内容: 这样,蚂蚁构建可以找到uspressions.xml,因为构建的基础是项目目录. 现在使用 checkstyle-plugin
0 2024-04-05
编程技术问答社区
如何以编程方式运行Eclipse启动配置?
我发现很难很好地表达这个问题,因为有很多通用术语(运行,配置,启动等).这里是: 您可以将run配置保存在.launch>中文件. (在"运行配置"对话框中,在"公共"选项卡下,另存为共享文件. 我们将其检查到SVN.开发人员可以将它们传递给它们,这有助于使新的开发人员更快地运行工作应用程序. 我想将其作为我们的构建的一部分进行检查,并使用它们来编程运行应用程序,测试等,而无需旋转整个IDE. 在UI之外运行.launch文件的最佳方法是什么? 编辑:我正在尝试统一在构建服务器和IDE上运行的测试.我不 特别想放弃集成调试,蚂蚁脚本进行测试就是这种情况. 这可能是与多个捆绑包的集成测试或单元测试整个捆绑包的问题,​​您想模拟扩展. 解决方案 在Junit上构建了一个Eclipse插件,称为TPTP.它提供了一个自动化客户端,可用于从没有GUI的Eclipse启动测试.也许有帮助 其他解决方案 不幸的是,这仅限于Java应用程序和Juni
8 2024-04-04
编程技术问答社区
Eclipse增量生成器插件不工作
我最近开始在Eclipse RCP(4.2.1 Juno)上使用Eclipse的插电式开发环境.我创建了一个使用增量构建器模板的项目.我的目标是在Java构建结束后,在用户代码上执行构建过程. 问题是,我不知道如何使用构建器.我尝试将项目导出到"可部署的插件和片段" jar文件中,然后将JAR文件放在多个位置,例如开发工作区,运行时工作区以及开发Eclipse的插件文件夹. 我将插件项目作为" Eclipse应用程序"运行,运行时蚀出现,我创建一个项目,并为该项目定义一个构建器,并将导出的Jar作为构建器文件作为构建器文件,并且是DIR,则为工作dir,然后构建项目和希望魔术发生!!但是愚蠢的我... 在所有情况下,我都会获得表格的许可: Errors occurred during the build. Errors running builder 'Integrated External Tool Builder' on project 'A'. Exception occur
8 2024-04-04
编程技术问答社区
黑莓HelloWorld在8130模拟器下在Eclipse中部署,但不是950
我遵循www.thinkingblackberry.com/archives/21 中的步骤 如果我使用8130模拟器选择4.5.0 JDE,我可以导航到Helloworld图标,单击它,应用程序运行,我可以点击断点等. i然后切换到4.7.0 jde,删除模拟器文件(blackberry |擦除模拟器文件|擦除全部),然后在debug配置中将模拟器从默认值从默认值更改为9500 运行模拟器时,在模拟器出现时,我会在Eclipse控制台窗口中获得一系列消息.如果我然后单击BB按钮获取更多图标,然后单击"应用程序"按钮,我看不到任何Helloworld图标,并且我看不到任何向上/向下箭头表明有更多图标.我想念明显的东西吗?这是我看到的: 事先感谢您的任何帮助. 克里斯 解决方案 选择文件 - >加载COD,然后选择您的应用程序COD文件.之后,您的应用程序将在Home->您的设备上下载文件夹.
12 2024-04-04
编程技术问答社区
如何为checkstyle定义抑制条件,使其同时适用于ant和eclipse。
我在项目CheckStyle中使用,并且已经定义了 suppressionfilter 配置.我使用Apache Ant通过连续集成进行自动构建. 我的问题来自以下情况:我不想将大量文件填充到基于项目的ir中,因此checkStyle.xml和puspressions.xml都在一个名为Conf的子目录中(用于构建的配置) .现在,蚂蚁和日食在寻找抑制作用方面有所不同.xml. ant使用基于项目的基于基于项目的抑制.xml,在我宣布蚂蚁任务以找到checkStyle.xml的基础配置.此checkStyle.xml现在包含以下内容: 这样,蚂蚁构建可以找到uspressions.xml,因为构建的基础是项目目录. 现在使用 checkstyle-plugin
4 2024-04-04
编程技术问答社区
从插件中以编程方式显示一个SWT浏览器
我正在尝试打开Eclipse的内部浏览器( org.eclipse.swt.browser.browser )从eclipse插件的代码中调用. 到目前为止,我实际上可以实例化一个,我可以"打开"一个URL(我可以告诉我设置的听众的登录).但是什么都没有出现.由于外壳被用作浏览器的复合父,我希望它将刚刚启动. 我找不到有关此特定问题的任何资源. 这是我到目前为止的代码: final Shell shell = myActiveWorkbenchWindow.getShell(); final Browser browser = new Browser(shell, SWT.NONE); // set up listener to log the url when loaded browser.setUrl(getLoginUrl()); 那么,我如何使浏览器出现(作为弹出窗口或在我的日食窗口中)? 解决方案 而不是将"浏览器"视为具有自己
8 2024-04-04
编程技术问答社区
缺少BlackberryPreprocessBuilder和BlackberrryResourceBuilder
我正在使用黑莓蚀Java插件1.5 我没有得到BB开发环境. the Riim Compiler 支撑的预处理指令 和使用blackberry jde插件中的预处理程序指令使用eclippese? 我使用了这些链接,但不起作用. Plaese帮助 解决方案 My recommendation is to use this latest download of Eclipse&插件. 黑莓工具不是很好,因此我发现最好仅适用于BB Dev.我发现此下载对我有效. 安装此版本 - 我认为它将解决您的所有问题.如果没有,请回复,我会看看是否可以进一步帮助.
4 2024-03-31
编程技术问答社区
黑莓错误。不能运行程序 "jar"。CreateProcess error=2, 系统无法找到指定文件
我有大量的类文件 回复:i/o错误:无法运行程序" jar":createProcess错误= 2,系统无法找到指定的文件,在运行应用程序时.如果我排除了某些类,则对我来说很好.解决此错误. 解决方案 我在包含很多课程的项目中遇到了完全相同的问题.由于类的增加,Java Jar文件从根部移开,这会导致编译中的问题. 我很幸运能够解决此错误. this 链接在BlackBerry支持论坛中非常有帮助.以下步骤解决了我的问题: 右键单击我的计算机.转到物业. 单击高级系统设置. 单击环境变量 突出显示路径,然后单击编辑.添加C:\程序文件 (x86)\ java \ jdk1.6.0_26 \ bin;到路径的开始. 步骤4将Java Jar文件添加到路径变量中,并将其添加到根部.在用几个类编译项目时,越来越接近根很有帮助. 其他解决方案 类的数量可能不是问题.这可能是由黑莓packager找不到jar.exe引起的. 默认的C:\ progra
18 2024-03-31
编程技术问答社区
缺少BlackberryPreprocessBuilder和BlackberrryResourceBuilder
我正在使用黑莓蚀Java插件1.5 我没有得到BB开发环境. the Riim Compiler 支撑的预处理指令 和使用blackberry jde插件中的预处理程序指令使用eclippese? 我使用了这些链接,但不起作用. Plaese帮助 解决方案 My recommendation is to use this latest download of Eclipse&插件. 黑莓工具不是很好,因此我发现最好仅适用于BB Dev.我发现此下载对我有效. 安装此版本 - 我认为它将解决您的所有问题.如果没有,请回复,我会看看是否可以进一步帮助.
6 2024-03-31
编程技术问答社区
请告诉我如何将黑莓和安卓整合到同一个IDE中。
我正在使用PhoneGap作为环境来开发代码.因此,我需要知道如何将BlackBerry和Android集成到同一IDE(Eclipse)中. 解决方案 Android: 更新网站: (Eclipse 3.4) https://dl-ssl.google.com/android.com/android/eclipse/eclipse/ /p> (Eclipse 3.5) https://dl-ssl.google.com/android.com/android/eclipse/eclipse/ /p> 黑莓(更新站点): (Eclipse 3.4) http://www.blackberry.com/go/colipseupdate (Eclipse 3.5)
10 2024-03-31
编程技术问答社区
请告诉我如何将黑莓和安卓整合到同一个IDE中。
我正在使用PhoneGap作为环境来开发代码.因此,我需要知道如何将BlackBerry和Android集成到同一IDE(Eclipse)中. 解决方案 Android: 更新网站: (Eclipse 3.4) https://dl-ssl.google.com/android.com/android/eclipse/eclipse/ /p> (Eclipse 3.5) https://dl-ssl.google.com/android.com/android/eclipse/eclipse/ /p> 黑莓(更新站点): (Eclipse 3.4) http://www.blackberry.com/go/colipseupdate (Eclipse 3.5)
2 2024-03-31
编程技术问答社区