Google Play游戏服务: ERROR_NOT_AUTHORIZED, when rollout for Beta
Google Play Games服务:SIGN_IN状态:error_not_authorized,for beta时. 还有: - W Auth : [GetToken] GetToken failed with status code: UNREGISTERED_ON_API_CONSOLE E TokenRequestor: You have wrong OAuth2 related configurations, please check. Detailed error: UNREGISTERED_ON_API_CONSOLE 如果我直接从Unity构建和运行,一切都很好. 但是,当我推出Beta时,它显示了带有加载圈的Google Green Box中的签名(然后是帐户 - >选择Beta测试器电子邮件),然后什么也没有. 使用: - Google Playgamesplugin-0.9.38a Unity 5.6.03 SDK组件更新了Rev
0 2024-04-11
编程技术问答社区
Android Studio:错误:执行任务失败':app:transformclasseswithjarmergingforrelease'
我正在尝试构建项目的签名APK,并且会收到以下错误: Error:Execution failed for task ':app:transformClassesWithJarMergingForRelease'. > com.android.build.api.transform.TransformException: java.util.zip.ZipException: duplicate entry: com/google/android/gms/common/internal/zzv$zza$zza.class 当我选择调试构建类型时,我没有错误,一切都很好.我搜索了一段时间来解决此问题,但没有发现任何有用的. 我的build.gradle: apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdk
0 2024-04-05
编程技术问答社区
如何在Android Studio中找到google play服务版本?
我试图将Google Play服务用于位置目的.因此,我想将Google Play服务添加到我的应用中.在build.gradle的依赖源,我添加了以下行. compile 'com.google.android.gms:play-services:9.0.1' 但是,它给出以下错误 Error:(25, 13) Failed to resolve: com.google.android.gms:play-services:9.0.1 我找不到安装了哪个版本的Google Play服务.在SDK工具选项卡中,它说版本30. 我也尝试了关注行,但也给出了相同的错误 compile 'com.google.android.gms:play-services:30' 编辑:这是整个build.gradle文件. apply plugin: 'com.android.application' android { compileSdk
0 2024-04-04
编程技术问答社区
Gradle不能设法添加编译'com.google.android.gms:play-services:7.0.0'。
我不能相信没有人发现如何解决这个问题.我想在我的应用程序中添加横幅,但是Android Studio的Gradle系统试图使我的主意并不是好主意.看起来这样: apply plugin: 'com.android.application' android { compileSdkVersion 21 buildToolsVersion "22.0.1" defaultConfig { applicationId "com.(package).(name)" minSdkVersion 15 targetSdkVersion 21 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false prog
0 2024-04-04
编程技术问答社区
无法解决com.google.android.gcm.GCMBaseIntentService;Android studio
编辑:我解决了这个问题:) 此错误的原因: 在实施GCM客户端的教程中,有 link 下载演示的完整源代码. 已下载供参考,在build.gradle中添加了Google_play_service库. 做了一些建议的更改,例如sender_id,server_url,.. etc 将项目与Gradle同步并获得此错误. 我如何解决! 在Google大量之后,我发现此类不在Google_play_service库中,而是在GCM.Jar中,现在已弃用. 我不知道为什么Google给出了旧代码的链接并解释了文档中的最新代码. 然后我包括gcm.jar 错误消失了,得到了通知:) 希望这将有助于遇到这种麻烦的人! 我的旧问题 我是Android Studio的新手.我不明白build.gradle.今天,我正在按照此处给出的指令实施GCM-DEMO-CLIENT,开源源代码我的错误时,我得到了以下错误. /home/shani/Desktop/
在运行wear模块时,得到 "多于一个包名为'com.google.android.gms'的库"。
我正在将磨损模块添加到应用程序中. (使用此示例代码作为参考) ) 所以我有3个模块,每个模块都取决于com.google.android.gms的版本:play-services: app-编译'com.google.android.gms:play -services:6.1.11' WEAR-'com.google.android.gms:Play-Services磨损:6.5.+' 共享 - 编译'com.google.android.gms:play -services:6.1.11' 编译磨损模块时,我会收到此错误: 错误:任务执行失败':磨损:ProcessDebugresources'. 错误:包含包名称'com.google.android.gms'的多个库 您可以使用android.enforceuniquepackagagename = false暂时禁用此错误 但是,这是暂时的,将在1.0 中执行 显然,如果我在Wear模块的构建中更
0 2024-04-04
编程技术问答社区
谷歌播放服务GCM 10.0.1要求 "更新 "至9.0.0
我正在尝试构建我的新项目,但是我得到了这个错误: 错误:任务执行失败':移动:processDebuggoogleservices'. 请通过更新Google-Services插件的版本来修复版本冲突(有关最新版本的信息,请 https://bintray.com/android/android-tools/com.google.gms.google-services/)或更新com.google.android.android .gms至9.0.0. apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdkVersion 25 buildToolsVersion "25.0.1" defaultConfig { applicationId "com.julia.android.
0 2024-04-04
编程技术问答社区
使用Proguard来删除Google Play服务库中未使用的类
我试图从Google Play Services库中摆脱未使用的课程.我已经创建了全新的Android项目,具有单个空的活动.该项目不使用Google Play Services库中的任何内容.因此,我希望,当我构建发行版时(其中包括在配置中运行proguard),我会发现二进制尺寸与具有/没有play-services依赖关系的构建相比没有差异.但是实际上,我看到apk尺寸的〜700 kb差异. 我已经找到了使用重新播放播放播放, services.jar文件.同样,该解决方案需要明确指定每个不会使用的软件包.但是我不明白为什么proguard在我的情况下不这样做? build.gradle: apply plugin: 'com.android.application' android { compileSdkVersion 21 buildToolsVersion "21.1.1" defaultConfig { min
com.android.build.transform.api.TransformException with android google play services
我正在尝试将Google Plus集成到我的应用程序中,并且显示以下错误.以下是例外和gradle 错误:任务执行失败':app:transformclasseswithdexfordebug'. com.android.build.transform.api.transformexception:com.android.ide.common.process.process.processexception:org.gradle.process.internal.execexecception:process'命令'c:c:\ program files \ java \ java \ jdk11 .7.0_79 \ bin \ java.exe''以非零退出值1 完成 应用程序build.gradle apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-servi
0 2024-04-04
编程技术问答社区
将Google Play服务升级到11.0.0版本后出现错误
我有一个奇怪的问题.将Google Play服务库从版本10.2.6上传到版本11.0.0之后,当我尝试编译时,我会收到此错误: 错误:任务执行失败':app:processdebuggoogleservices'. 请通过更新Google-Services插件的版本来修复版本冲突(有关最新版本的信息,请 https://bintray.com/android/android-tools/com.google.gms.google-services/)或更新com.google.android.android .gms至11.0.0. 我访问了该错误中提到的链接,最后版本的Google-Services插件似乎是3.1.0,即我使用的版本,我已经将所有Play Services库升级为11.0.0版本.我该怎么做才能使用11.0.0版本的GMS编译代码? 这是我的build.gradle文件(模块范围): apply plugin: 'com.android.ap
0 2024-04-04
编程技术问答社区
更新后-错误:未能找到:com.google.android.gms:play-services:5.2.8
gradle项目同步失败. 更新Android SDK后,我得到了此错误: 错误:找不到:com.google.android.gms:Play-Services:5.2.8 我检查了已更新的SDK位置由Android Studio使用 我已经安装了Google存储库,并且也已安装了Android支持存储库. 我也有一个android_home本地变量,指向我实际使用的SDK 解决方案 尝试使用com.google.android.gms:Play-Services:5.2.08而不是5.2.8. 您还可以在服务目录中查找正确的版本号: ../android-studio/sdk/extras/google/m2repository/com/google/google/android/gms/play-services/ 其他解决方案 检查您的SDK附加软件包,您需要安装: Google Play服务 Google存储库 对
0 2024-04-04
编程技术问答社区
我如何将Google Play服务的修订版与安装版本相匹配?
Android SDK Manager今天早上通知我,有一个新的Google Play Services发布要下载:修订18.那么我如何找到要放入我的build.gradle文件中的相应的长版本号?我所有的测试设备均为运行5.0.84,所以我尝试更新 compile 'com.google.android.gms:play-services:4.4.52' to compile 'com.google.android.gms:play-services:5.0.84' 但这导致了错误: gradle'myapp'项目刷新失败:找不到com.google.android.gms:Play-Services:5.0.84.要求: {我的app} gradle设置 我正在运行Android Studio 0.5.2并为API19建造(我尚未升级到Android L/API20):也许这是问题?但是通常,您如何将SDK Manager(例如18)中显示的修订号与b
2 2024-04-04
编程技术问答社区
JavaFX安卓端口-谷歌游戏服务
我已经在Javafx上写了一个小游戏,并成功地将其移植到了Android.现在,我想包括一些Google广告.为此,我创建了一个PlatformService和AndroidPlatFormProvider,例如在此示例所示.我正在使用NetBeans的Gluon插件 我将其添加到我的build.gradle文件: repositories { def androidHome = System.getenv("ANDROID_HOME") maven { url "$androidHome/extras/android/m2repository/" } maven { url "$androidHome/extras/google/m2repository/"} } dependencies { compile fileTree(include: ['*.jar'], dir: 'libs') compile 'com.go
2 2024-04-04
编程技术问答社区
任务':app:processReleaseGoogleServices'的执行失败。> 没有找到与软件包名称相匹配的客户端
每当我尝试构建项目时,我都会遇到此错误: Execution failed for task ':app:processReleaseGoogleServices'. No matching client found for package name 'com.my.package' 我已经制作了google-services.json并使用了该应用程序和软件包com.my.package. 这是我的项目build.gradle: buildscript { repositories { ... } dependencies { classpath 'com.android.tools.build:gradle:2.0.0-beta6' classpath 'com.github.JakeWharton:sdk-manager-plugin:220bf7a88a7072df3ed16dc8466fb144f2817070'
8 2024-04-04
编程技术问答社区
无法解决符号'GooglePlayServicesClient'。
我正在尝试将一个项目从Eclipse迁移到Android Studio,该项目可以在Eclipse中构建,并成功地进口到Android Studio,但是,我在Android Studio中遇到了Cannot resolve symbol 'GooglePlayServicesClient'错误. 我遵循官方教程,在Android Studio中导入Google Play服务,以及我项目中使用的其他软件包" com.google.android.gms.common.ConnectionResult"也没有相同的问题. 唯一的'GooglePlayServicesClient'无法解决. 我也尝试过干净并重建我的项目,但是问题仍然存在.我在做什么错? 更新: 我的build.gradle ... dependencies { compile project(':libraryListViewAnimations') compile 'com
0 2024-04-04
编程技术问答社区
Android Studio Gradle。Error:Execution failed for task ':app:processDebugGoogleServices'. > 没有为包找到匹配的客户端
我正在尝试通过以下示例将Google Play服务依赖关系升级为8.4.0 app/build.gradle">在这里,但是我会收到以下错误('com.example.exampleapp'是我的应用程序包名称的替代): Error:Execution failed for task ':app:processDebugGoogleServices'. > No matching client found for package name 'com.example.exampleapp' 项目build.gradle: buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.0.0-alpha3' classpath 'com.google.gms:googl
java.lang.IllegalAccessError: 方法 'void android.support.v4.content
我在我的SDK中更新了PlayService,并且得到了此错误.而且我无法访问GCM令牌.在更新SDK之前,我的项目完美工作. 我浪费了整天,但没有找到任何解决方案.我尝试了 this 但是在此依赖项中遇到错误com.google.android.gms:play-services-plus:9.0.0 com.google.android.gms:play-services-plus:9.0.0 P> 这是我的 logcat Caused by: java.lang.IllegalAccessError: Method 'void android.support.v4.content.ContextCompat.()' is inaccessible to class 'com.google.android.gms.iid.zzd' (declaration of 'com.google.android.gms.iid.zzd' appears in /dat
4 2024-04-04
编程技术问答社区
如何修复谷歌游戏服务错误
今天在Root文件夹中更新播放服务后,我将面临以下问题.我很困惑如何解决这个问题. 任何人都可以帮我解决这个问题吗? 这个错误很刺激.我不知道冲突在哪里.顺便说一下,为什么它显示冲突而没有任何版本相互关联. 错误: 图书馆com.google.android.gms:play-services-measurement base是 由其他各个库的要求[[15.0.0.0,15.0.0], [15.0.2,15.0.2]],但决心为15.0.2.禁用插件并检查 使用./gradlew:app:依赖项. build.gradle 脚本: apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { configurations.all { resolutionStrategy.force 'com.google.c
8 2024-04-04
编程技术问答社区
错误: 请通过更新google-services插件的版本来解决版本冲突问题。
我在Google Services插件上有问题. 我将Google服务更新为最新版本.我从这个网站获得了依赖性: https://bintray .com/android/android-tools/com.google.gms.google-services/ Error:Execution failed for task ':app:processDebugGoogleServices'. > Please fix the version conflict either by updating the version of the google-services plugin (information about the latest version is available at https://bintray.com/android/android-tools/com.google.gms.google-services/) or updating the versi
在测试安卓广播时,如何包含一个捆绑的额外内容?
我目前正在尝试测试Google的应用程序邀请,但是我很难测试INSTALL_REFERRER广播功能,而无需在Play商店中放置应用程序 应用程序邀请广播意图需要一个额外的捆绑命名"com.google.android.gms.appinvite.REFERRAL_BUNDLE",并在AppInviteReferral中检查了: public static boolean hasReferral(Intent referralIntent) { return referralIntent != null && referralIntent.getBundleExtra("com.google.android.gms.appinvite.REFERRAL_BUNDLE") != null; } 使用adb shell am broadcast ...测试广播时,我们能做的最好的就是添加其他功能,但是没有选项可以添加额外的捆绑包. ( documentatio
0 2024-04-03
编程技术问答社区